← Back to SOC feed Coverage →

Admin Submissions by Grading verdict (FN-FP)

kql MEDIUM Azure-Sentinel
T1566
CloudAppEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-18T11:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may exploit false negative or false positive grading verdicts to bypass detection and maintain persistence within the environment. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify potential evasion tactics and refine detection rules.

KQL Query

CloudAppEvents
| where ActionType contains "AdminSubmissionTriage"
| extend UserKey = (parse_json(RawEventData)).UserKey, SubmissionState = (parse_json(RawEventData)).SubmissionState,  SubmissionId=(parse_json(RawEventData)).SubmissionId, TriageVerdict=(parse_json(RawEventData)).GradingResult.TriageVerdict
| summarize count() by tostring(TriageVerdict)
| render piechart

Analytic Rule Definition

id: f7a36ec9-f708-420c-b248-7dfe6cc39d0a
name: Admin Submissions by Grading verdict (FN-FP)
description: |
  This query visualises the total amount of admin false negative or false positive submissions by the verdict of the submission grading.
description-detailed: |
  This query visualises the total amount of admin false negative or false positive submissions by the verdict of the submission grading.
  Query is also included as part of the Defender for Office 365 solution in Sentinel: https://techcommunity.microsoft.com/blog/microsoftdefenderforoffice365blog/part-2-build-custom-email-security-reports-and-dashboards-with-workbooks-in-micr/4411303
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - CloudAppEvents
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  CloudAppEvents
  | where ActionType contains "AdminSubmissionTriage"
  | extend UserKey = (parse_json(RawEventData)).UserKey, SubmissionState = (parse_json(RawEventData)).SubmissionState,  SubmissionId=(parse_json(RawEventData)).SubmissionId, TriageVerdict=(parse_json(RawEventData)).GradingResult.TriageVerdict
  | summarize count() by tostring(TriageVerdict)
  | render piechart
version: 1.0.0

Required Data Sources

Sentinel TableNotes
CloudAppEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/Submissions/Admin Submissions by Grading Verdict - FN-FP.yaml