← Back to SOC feed Coverage →

BEC - File sharing tactics - Dropbox

kql MEDIUM Azure-Sentinel
T1021
CloudAppEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-10T23:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may use Dropbox to exfiltrate data or share malicious files as part of business email compromise tactics. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify potential exfiltration channels and mitigate BEC attacks early.

KQL Query

CloudAppEvents
| where ActionType in ("Added users and/or groups to shared file/folder", "Invited user to Dropbox and added them to shared file/folder")
| where Application == "Dropbox"
| where ObjectType == "File"
| extend FileShared = tostring(ObjectName)
| where isnotempty(FileShared)
| mv-expand ActivityObjects
| where ActivityObjects.Type == "Account" and ActivityObjects.Role == "To"
| extend SharedBy = AccountId
| extend UserSharedWith = tostring(ActivityObjects.Name)
| summarize dcount(UserSharedWith) by FileShared, AccountObjectId
| where dcount_UserSharedWith >= 20

Analytic Rule Definition

id: 6e056084-8951-460d-93f9-525880062de9
name: BEC - File sharing tactics - Dropbox
description: |
  This query helps hunting for BEC - File sharing tactics - Dropbox
description-detailed: |
  This query helps hunting for BEC - File sharing tactics - Dropbox. 
  It highlights that highlights that a file hosted on Dropbox has been shared with multiple participants.
  Shared by Microsoft Threat Intelligence: https://www.microsoft.com/en-us/security/blog/2024/10/08/file-hosting-services-misused-for-identity-phishing/
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - CloudAppEvents
tactics:
  - LateralMovement
relevantTechniques:
  - T1021
query: |
  CloudAppEvents
  | where ActionType in ("Added users and/or groups to shared file/folder", "Invited user to Dropbox and added them to shared file/folder")
  | where Application == "Dropbox"
  | where ObjectType == "File"
  | extend FileShared = tostring(ObjectName)
  | where isnotempty(FileShared)
  | mv-expand ActivityObjects
  | where ActivityObjects.Type == "Account" and ActivityObjects.Role == "To"
  | extend SharedBy = AccountId
  | extend UserSharedWith = tostring(ActivityObjects.Name)
  | summarize dcount(UserSharedWith) by FileShared, AccountObjectId
  | where dcount_UserSharedWith >= 20
version: 1.0.0

Required Data Sources

Sentinel TableNotes
CloudAppEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/Hunting/BEC - File sharing tactics - Dropbox.yaml