← Back to SOC feed Coverage →

c2-lookup-from-nonbrowser[Nobelium]

kql MEDIUM Azure-Sentinel
DeviceEvents
aptbackdoorhuntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-06T11:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries are using non-browser-based C2 communication to establish persistent command and control channels, indicative of the Nobelium campaign. SOC teams should proactively hunt for this behavior in Azure Sentinel to detect and mitigate advanced persistent threats that evade traditional network detection methods.

KQL Query

DeviceEvents
| where ActionType == "DnsQueryResponse" //DNS Query Response
and AdditionalFields has ".avsvmcloud"

Analytic Rule Definition

id: f7dd2c5f-7bb3-4a0a-80a1-45c4d79e4c03
name: c2-lookup-from-nonbrowser[Nobelium]
description: |
  This query was originally published in the threat analytics report, Solorigate supply chain attack. Please note that these attacks are currently known as the Nobelium campaign.
  Microsoft detects the 2020 SolarWinds supply chain attack implant and its other components as part of a campaign by the Nobelium activity group. Nobelium is the threat actor behind the attack against SolarWinds, which was previously referred to as Solorigate.
  Nobelium silently added malicious code to legitimate software updates for Orion, which is IT monitoring software provided by SolarWinds. In this way, malicious dynamic link libraries (DLLs) were distributed to SolarWinds customers.
  The following query detects events when Nobelium received a DNS response after launching a lookup request to known command-and-control infrastructure.
  More Nobelium-related queries can be found listed under the See also section of this document.
  References:
  https://msrc-blog.microsoft.com/2020/12/13/customer-guidance-on-recent-nation-state-cyber-attacks/
  https://www.microsoft.com/security/blog/2020/12/18/analyzing-solorigate-the-compromised-dll-file-that-started-a-sophisticated-cyberattack-and-how-microsoft-defender-helps-protect/
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceEvents
tactics:
- Command and control
tags:
- Nobelium
query: |
  DeviceEvents
  | where ActionType == "DnsQueryResponse" //DNS Query Response
  and AdditionalFields has ".avsvmcloud"

Required Data Sources

Sentinel TableNotes
DeviceEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Campaigns/c2-lookup-from-nonbrowser[Nobelium].yaml