← Back to SOC feed Coverage →

check-for-shadowhammer-activity-download-domain

kql MEDIUM Azure-Sentinel
DeviceNetworkEvents
backdoorhuntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-07T23:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may be leveraging compromised ASUS update domains to download malicious payloads, indicating potential supply chain compromise. SOC teams should proactively hunt for this behavior in Azure Sentinel to detect and mitigate ShadowHammer-like supply chain attacks targeting enterprise systems.

KQL Query

DeviceNetworkEvents 
| where Timestamp > ago(30d)
| where RemoteUrl == "asushotfix.com" or RemoteIP == "141.105.71.116"

Analytic Rule Definition

id: 1217e1fd-ebbb-4fdc-8b18-81be69876b3a
name: check-for-shadowhammer-activity-download-domain
description: |
  This query was originally published in the threat analytics report, ShadowHammer supply chain attack
  Operation ShadowHammer was an attack against ASUS computer hardware, using the company's own update infrastructure to deliver malware to the company's products. The campaign ran from June to November, 2018. ASUS has since responded with updates that protect their Live Update system, and diagnostic tools to check affected systems.
  The following query checks for activity associated with the ShadowHammer download domain over the past 30 days.
  References:
  https://www.vice.com/en_us/article/pan9wn/hackers-hijacked-asus-software-updates-to-install-backdoors-on-thousands-of-computers
  https://www.asus.com/News/hqfgVUyZ6uyAyJe1
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceNetworkEvents
tactics:
- Command and control
query: |
  DeviceNetworkEvents 
  | where Timestamp > ago(30d)
  | where RemoteUrl == "asushotfix.com" or RemoteIP == "141.105.71.116"

Required Data Sources

Sentinel TableNotes
DeviceNetworkEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Command and Control/check-for-shadowhammer-activity-download-domain.yaml