← Back to SOC feed Coverage →

ConnectedNetworkDeviceDiscovery

kql MEDIUM Azure-Sentinel
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-09T11:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may use network discovery to identify and target connected devices within the environment. SOC teams should proactively hunt for this behavior to detect potential reconnaissance efforts and early-stage compromise attempts in their Azure Sentinel environment.

KQL Query

DeviceNetworkInfo
| mv-expand parse_json(IPAddresses)
| mv-expand parse_json(ConnectedNetworks)
| where IPAddresses.IPAddress !contains ":" and IPAddresses.IPAddress <> ""
| where ConnectedNetworks.Name == "YourNetworkHere" and ConnectedNetworks.Name <> "" //Change the YourNetworkHere to the display
| summarize arg_max(Timestamp, *) by DeviceName
| project DeviceName, IPAddress=IPAddresses.IPAddress, ConnectedNetworks_value=ConnectedNetworks.Name

Analytic Rule Definition

id: c7813a5c-ef11-4ee9-8feb-731402f31259
name: ConnectedNetworkDeviceDiscovery
description: |
  Find devices connected to a monitored network. 
  Please Note line 5 needs to have a monitored network name put in place or commented out to pull everything.
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceNetworkEvents
query: |
    DeviceNetworkInfo
    | mv-expand parse_json(IPAddresses)
    | mv-expand parse_json(ConnectedNetworks)
    | where IPAddresses.IPAddress !contains ":" and IPAddresses.IPAddress <> ""
    | where ConnectedNetworks.Name == "YourNetworkHere" and ConnectedNetworks.Name <> "" //Change the YourNetworkHere to the display
    | summarize arg_max(Timestamp, *) by DeviceName
    | project DeviceName, IPAddress=IPAddresses.IPAddress, ConnectedNetworks_value=ConnectedNetworks.Name

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Discovery/ConnectedNetworkDeviceDiscovery.yaml