← Back to SOC feed Coverage →

cypherpunk-exclusive-commands

kql MEDIUM Azure-Sentinel
DeviceProcessEvents
backdoorhuntingmicrosoftofficialransomware
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-06T23:00:00Z · Confidence: medium

Hunt Hypothesis

The cypherpunk-exclusive-commands rule detects potential Cypherpunk ransomware activity through the execution of unique, adversary-specific commands that indicate tampering with antivirus solutions. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify and mitigate ransomware attacks that evade traditional detection methods.

KQL Query

// Searches for possible Cypherpunk ransomware activity
DeviceProcessEvents
| where InitiatingProcessParentFileName startswith "psexe"
| where ProcessCommandLine has "Dvr /go"

Analytic Rule Definition

id: 2affa440-24b5-48b2-a377-d5968a499658
name: cypherpunk-exclusive-commands
description: |
  This query was originally published in the threat analytics report, Cypherpunk ransomware leaves wake of tampered AVs.
  Cypherpunk is a human-operated ransomware campaign named after the unusual .cypherpunk extension given to encrypted files.
  The query below surfaces commands that follow the distinctive pattern Cypherpunk operators would use to remotely execute code.
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceProcessEvents
tactics:
- Execution
- Ransomware
query: |
  // Searches for possible Cypherpunk ransomware activity
  DeviceProcessEvents
  | where InitiatingProcessParentFileName startswith "psexe"
  | where ProcessCommandLine has "Dvr /go"

Required Data Sources

Sentinel TableNotes
DeviceProcessEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Campaigns/cypherpunk-exclusive-commands.yaml