← Back to SOC feed Coverage →

Devices By Specific DeviceType and DeviceSubtype

kql MEDIUM Azure-Sentinel
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-08T23:00:01Z · Confidence: medium

Hunt Hypothesis

Devices of a specific type and subtype may indicate the presence of compromised or unauthorized hardware that could be used as a pivot point in an attack. SOC teams should proactively hunt for this behavior to identify potential lateral movement or persistence mechanisms in their Azure Sentinel environment.

KQL Query

// Specify the wanted DeviceType and/or DeviceSubtype
let HuntedDeviceType = "NetworkDevice";
let HuntedDeviceSubtype = "Router";
DeviceInfo
| summarize arg_max(Timestamp, *) by DeviceId
| where DeviceType == HuntedDeviceType and DeviceSubtype  == HuntedDeviceSubtype

Analytic Rule Definition

id: 88adf141-5058-4f0f-a665-cd56eed754a5
name: Devices By Specific DeviceType and DeviceSubtype
description: |
  This query finds devices by DeviceType and/or DeviceSubtype
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceInfo
tactics: []
relevantTechniques: []
query: |
  // Specify the wanted DeviceType and/or DeviceSubtype
  let HuntedDeviceType = "NetworkDevice";
  let HuntedDeviceSubtype = "Router";
  DeviceInfo
  | summarize arg_max(Timestamp, *) by DeviceId
  | where DeviceType == HuntedDeviceType and DeviceSubtype  == HuntedDeviceSubtype

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Device Inventory/Devices By Specific DeviceType and DeviceSubtype.yaml