← Back to SOC feed Coverage →

Dropbox downloads linked from other site

kql MEDIUM Azure-Sentinel
DeviceFileEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-08T23:00:01Z · Confidence: medium

Hunt Hypothesis

Adversaries may use Dropbox links hosted on third-party sites to exfiltrate data or deploy malware by masquerading as legitimate file downloads. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify potential data exfiltration or malware distribution channels leveraging trusted file-sharing services.

KQL Query

DeviceFileEvents
| where 
    Timestamp > ago(7d)
    and FileOriginUrl startswith "https://dl.dropboxusercontent.com/"
    and isnotempty(FileOriginReferrerUrl)
    and FileOriginReferrerUrl !startswith "https://www.dropbox.com/" 
| project FileOriginReferrerUrl, FileName 

Analytic Rule Definition

id: de93670b-a1db-4c8c-80aa-5b3146428631
name: Dropbox downloads linked from other site
description: |
  This query looks for user content downloads from dropbox that originate from a link/redirect from a 3rd party site.
  File sharing sites such as Dropbox are often used for hosting malware on a reputable site.
  Read more about download URL data and about this attack vector in this blog post:.
  Https://techcommunity.microsoft.com/t5/Threat-Intelligence/Hunting-tip-of-the-month-Browser-downloads/td-p/220454.
  Tags: #DownloadUrl, #Referer, #Dropbox.
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceFileEvents
query: |
  DeviceFileEvents
  | where 
      Timestamp > ago(7d)
      and FileOriginUrl startswith "https://dl.dropboxusercontent.com/"
      and isnotempty(FileOriginReferrerUrl)
      and FileOriginReferrerUrl !startswith "https://www.dropbox.com/" 
  | project FileOriginReferrerUrl, FileName 

Required Data Sources

Sentinel TableNotes
DeviceFileEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Delivery/Dropbox downloads linked from other site.yaml