← Back to SOC feed Coverage →

Email Top 15 Targeted Users (Spam) with Additional Details

kql MEDIUM Azure-Sentinel
T1566
EmailEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-17T23:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may be targeting specific high-value users through spam to deliver phishing payloads or initial access. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify and mitigate potential compromise of critical accounts.

KQL Query

//This query visualises total inbound emails with Spam detections summarizing the data by the top 15 recipient email address (RecipientEmailAddress).
EmailEvents
| where ThreatTypes has "Spam" and EmailDirection =="Inbound"
| where Timestamp > ago(90d) // last 30 days by default, replace 30d with the desired period
| summarize count() by RecipientEmailAddress
| sort by count_ desc
| take 15
| project RecipientEmailAddress,Emails=count_

Analytic Rule Definition

id: 3e33ce02-b74e-49cc-899d-0a1eb3128ee3
name: Email Top 15 Targeted Users (Spam) with Additional Details
description: |
  This query visualises top 15 users targeted with Spam with summarized spam detections.
description-detailed: |
  This query visualises total inbound emails with Spam detections summarizing the data by the top 15 recipient email address (RecipientEmailAddress).
  Taken from the the Microsoft Defender for Office 365 Detections and Insights - Microsoft Sentinel workbook.
  https://techcommunity.microsoft.com/blog/microsoftdefenderforoffice365blog/part-2-build-custom-email-security-reports-and-dashboards-with-workbooks-in-micr/4411303
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - EmailEvents
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  //This query visualises total inbound emails with Spam detections summarizing the data by the top 15 recipient email address (RecipientEmailAddress).
  EmailEvents
  | where ThreatTypes has "Spam" and EmailDirection =="Inbound"
  | where Timestamp > ago(90d) // last 30 days by default, replace 30d with the desired period
  | summarize count() by RecipientEmailAddress
  | sort by count_ desc
  | take 15
  | project RecipientEmailAddress,Emails=count_
version: 1.0.0

Required Data Sources

Sentinel TableNotes
EmailEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/Spam/Spam Detection Top15 Users Details.yaml