← Back to SOC feed Coverage →

EmojiHunt

kql MEDIUM Azure-Sentinel
DeviceProcessEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-22T11:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may rename systems to emojis or pizza-related names to evade detection and blend in with legitimate system names. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify potential obfuscation tactics used by attackers to hide their presence.

KQL Query

DeviceProcessEvents
| distinct DeviceName
| extend fakeescape=replace("%5f", "_", replace("%2d", "-", url_encode(DeviceName)))
| where fakeescape != DeviceName

Analytic Rule Definition

id: 3e246f82-6a80-4cd3-8d4c-8afa2b7451d2
name: EmojiHunt
description: |
  Did you know you can use Emojis in Windows?.
  Read more here: https://davidzych.com/abusing-emoji-in-windows.
  Check-out who in your organization has renamed his or her computer to a Pizza or to a smiling poop.
  You might be amused by the results, or perhaps angry if one of your systems or scripts was broken by this...
  Note: this query will also return some machines with non-English charcters that are not Emojis.
  Credit for this query goes to miflower - thanks for bringing joy to our lives! :).
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceProcessEvents
query: |
  DeviceProcessEvents
  | distinct DeviceName
  | extend fakeescape=replace("%5f", "_", replace("%2d", "-", url_encode(DeviceName)))
  | where fakeescape != DeviceName

Required Data Sources

Sentinel TableNotes
DeviceProcessEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Fun/EmojiHunt.yaml