← Back to SOC feed Coverage →

Empty Sender Phish Delivered to Inbox

kql MEDIUM Azure-Sentinel
T1566
EmailEvents
huntingmicrosoftofficialphishing
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-09T23:00:01Z · Confidence: medium

Hunt Hypothesis

Phishing emails with an empty sender field are likely used to bypass email filtering and deliver malicious content to users’ inboxes. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify and mitigate potential spear-phishing campaigns that evade standard detection mechanisms.

KQL Query

EmailEvents
| where EmailDirection == "Inbound"
| where SenderIPv4 startswith "27.121.5." //IP range in Japan observed in this phishing campaign
| where isempty(SenderFromAddress) and isempty(SenderDisplayName) and SenderMailFromAddress == "<>"
| where DeliveryAction != "Blocked"

Analytic Rule Definition

id: c853b6d9-b33b-4172-8b18-e95e8d902e31
name: Empty Sender Phish Delivered to Inbox
description: |
  This query detects delivered phishing emails where the Sender is empty based on recently observed campaigns.
description-detailed: |
  This query detects delivered phishing emails where the Sender is empty based on recently observed campaigns. It can be used as a Continuous (NRT) Custom Detection Rule to trigger an automated action and delete the emails.
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - EmailEvents
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  EmailEvents
  | where EmailDirection == "Inbound"
  | where SenderIPv4 startswith "27.121.5." //IP range in Japan observed in this phishing campaign
  | where isempty(SenderFromAddress) and isempty(SenderDisplayName) and SenderMailFromAddress == "<>"
  | where DeliveryAction != "Blocked"
version: 1.0.0

Required Data Sources

Sentinel TableNotes
EmailEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/Custom Detections/Empty Sender Phish Delivered to Inbox.yaml