← Back to SOC feed Coverage →

Execution via stordiag.exe

sigma HIGH SigmaHQ
T1218
imProcessCreate
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at SigmaHQ →
Retrieved: 2026-05-20T11:00:00Z · Confidence: medium

Hunt Hypothesis

Detects the use of stordiag.exe to execute schtasks.exe systeminfo.exe and fltmc.exe

Detection Rule

Sigma (Original)

title: Execution via stordiag.exe
id: 961e0abb-1b1e-4c84-a453-aafe56ad0d34
status: test
description: Detects the use of stordiag.exe to execute schtasks.exe systeminfo.exe and fltmc.exe
references:
    - https://strontic.github.io/xcyclopedia/library/stordiag.exe-1F08FC87C373673944F6A7E8B18CD845.html
    - https://twitter.com/eral4m/status/1451112385041911809
author: Austin Songer (@austinsonger)
date: 2021-10-21
modified: 2022-12-25
tags:
    - attack.stealth
    - attack.t1218
logsource:
    category: process_creation
    product: windows
detection:
    selection:
        ParentImage|endswith: '\stordiag.exe'
        Image|endswith:
            - '\schtasks.exe'
            - '\systeminfo.exe'
            - '\fltmc.exe'
    filter:
        ParentImage|startswith: # as first is "Copy c:\windows\system32\stordiag.exe to a folder"
            - 'c:\windows\system32\'
            - 'c:\windows\syswow64\'
    condition: selection and not filter
falsepositives:
    - Legitimate usage of stordiag.exe.
level: high

KQL (Azure Sentinel)

imProcessCreate
| where ((ParentProcessName endswith "\\stordiag.exe" or ActingProcessName endswith "\\stordiag.exe") and (TargetProcessName endswith "\\schtasks.exe" or TargetProcessName endswith "\\systeminfo.exe" or TargetProcessName endswith "\\fltmc.exe")) and (not(((ParentProcessName startswith "c:\\windows\\system32\\" or ParentProcessName startswith "c:\\windows\\syswow64\\") or (ActingProcessName startswith "c:\\windows\\system32\\" or ActingProcessName startswith "c:\\windows\\syswow64\\"))))

Required Data Sources

Sentinel TableNotes
imProcessCreateEnsure this data connector is enabled

False Positive Guidance

MITRE ATT&CK Context

References

Original source: https://github.com/SigmaHQ/sigma/blob/master/rules/windows/process_creation/proc_creation_win_stordiag_susp_child_process.yml