← Back to SOC feed Coverage →

File download events in the last 7 days

kql MEDIUM Azure-Sentinel
CloudAppEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-07T11:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may be exfiltrating data by downloading sensitive files from cloud storage through Microsoft Defender for Cloud Apps. SOC teams should proactively hunt for this behavior to identify potential data exfiltration attempts and mitigate lateral movement or data theft risks in their Azure Sentinel environment.

KQL Query

let LookBack = 7d; CloudAppEvents | where ActionType == "FileDownloaded" and Timestamp > ago(LookBack) | extend FileName = RawEventData.SourceFileName | extend Site = RawEventData.SiteUrl | extend FileLabel = RawEventData.SensitivityLabelId | extend SiteLabel = RawEventData.SiteSensitivityLabelId | project Timestamp,AccountObjectId,AccountDisplayName,ActionType,Application,FileName,Site,FileLabel,SiteLabel

Analytic Rule Definition

id: f8f8d4a5-7d7d-4c5d-9b5c-9c5d7d8f8f8f
name: File download events in the last 7 days
description: |
  This query looks for file download events identified by Microsoft Defender for Cloud Apps. It will require an corresponding app connector in Microsoft Defender for Cloud Apps.
  Reference - https://learn.microsoft.com/defender-cloud-apps/enable-instant-visibility-protection-and-governance-actions-for-your-apps
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - CloudAppEvents
tactics:
- Exfiltration
query: >
  let LookBack = 7d;
  CloudAppEvents
  | where ActionType == "FileDownloaded" and Timestamp > ago(LookBack)
  | extend FileName = RawEventData.SourceFileName
  | extend Site = RawEventData.SiteUrl
  | extend FileLabel = RawEventData.SensitivityLabelId
  | extend SiteLabel = RawEventData.SiteSensitivityLabelId
  | project Timestamp,AccountObjectId,AccountDisplayName,ActionType,Application,FileName,Site,FileLabel,SiteLabel
entityMappings:
  - entityType: Account
    fieldMappings:
      - identifier: ObjectGuid
        columnName: AccountObjectId
      - identifier: DisplayName
        columnName: AccountDisplayName
version: 1.0.0

Required Data Sources

Sentinel TableNotes
CloudAppEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Cloud Apps/file-download-events.yaml