← Back to SOC feed Coverage →

Group quarantine release

kql MEDIUM Azure-Sentinel
T1566
CloudAppEventsEmailEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-17T11:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may be leveraging group quarantine release events to exfiltrate data or evade detection by manipulating mailbox activity. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify potential data exfiltration or evasion tactics tied to email security controls.

KQL Query

CloudAppEvents 
| where ActionType == "QuarantineReleaseMessage"
| extend parsed=parse_json(RawEventData)
| extend NetworkMessageId = tostring(parsed.NetworkMessageId)
| join EmailEvents on NetworkMessageId
| summarize count() by DetectionMethods
| order by count_ desc

Analytic Rule Definition

id: a12cac64-ea6d-46d4-91a6-262b165fb9ad
name: Group quarantine release
description: |
  This query helps in reviewing group Quarantine released messages by detection type. Useful to see what is leading to the largest number of messages being released.
description-detailed: |
  This query helps in reviewing group Quarantine released messages by detection type in Defender for Office 365. Useful to see what is leading to the largest number of messages being released.
requiredDataConnectors:
  - connectorId: MicrosoftThreatProtection
    dataTypes:
      - EmailEvents
      - CloudAppEvents
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  CloudAppEvents 
  | where ActionType == "QuarantineReleaseMessage"
  | extend parsed=parse_json(RawEventData)
  | extend NetworkMessageId = tostring(parsed.NetworkMessageId)
  | join EmailEvents on NetworkMessageId
  | summarize count() by DetectionMethods
  | order by count_ desc
version: 1.0.0

Required Data Sources

Sentinel TableNotes
CloudAppEventsEnsure this data connector is enabled
EmailEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/Quarantine/Group quarantine release.yaml