← Back to SOC feed Coverage →

HackTool - Covenant PowerShell Launcher

sigma HIGH SigmaHQ
T1059.001T1564.003
imProcessCreate
powershell
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at SigmaHQ →
Retrieved: 2026-05-08T23:00:01Z · Confidence: medium

Hunt Hypothesis

Detects suspicious command lines used in Covenant luanchers

Detection Rule

Sigma (Original)

title: HackTool - Covenant PowerShell Launcher
id: c260b6db-48ba-4b4a-a76f-2f67644e99d2
status: test
description: Detects suspicious command lines used in Covenant luanchers
references:
    - https://posts.specterops.io/covenant-v0-5-eee0507b85ba
author: Florian Roth (Nextron Systems), Jonhnathan Ribeiro, oscd.community
date: 2020-06-04
modified: 2023-02-21
tags:
    - attack.execution
    - attack.stealth
    - attack.t1059.001
    - attack.t1564.003
logsource:
    category: process_creation
    product: windows
detection:
    selection_1:
        CommandLine|contains|all:
            - '-Sta'
            - '-Nop'
            - '-Window'
            - 'Hidden'
        CommandLine|contains:
            - '-Command'
            - '-EncodedCommand'
    selection_2:
        CommandLine|contains:
            - 'sv o (New-Object IO.MemorySteam);sv d '
            - 'mshta file.hta'
            - 'GruntHTTP'
            - '-EncodedCommand cwB2ACAAbwAgA'
    condition: 1 of selection_*
level: high

KQL (Azure Sentinel)

imProcessCreate
| where ((TargetProcessCommandLine contains "-Sta" and TargetProcessCommandLine contains "-Nop" and TargetProcessCommandLine contains "-Window" and TargetProcessCommandLine contains "Hidden") and (TargetProcessCommandLine contains "-Command" or TargetProcessCommandLine contains "-EncodedCommand")) or (TargetProcessCommandLine contains "sv o (New-Object IO.MemorySteam);sv d " or TargetProcessCommandLine contains "mshta file.hta" or TargetProcessCommandLine contains "GruntHTTP" or TargetProcessCommandLine contains "-EncodedCommand cwB2ACAAbwAgA")

Required Data Sources

Sentinel TableNotes
imProcessCreateEnsure this data connector is enabled

False Positive Guidance

No known false positives documented.

MITRE ATT&CK Context

References

Original source: https://github.com/SigmaHQ/sigma/blob/master/rules/windows/process_creation/proc_creation_win_hktl_covenant.yml