← Back to SOC feed Coverage →

HackTool - GMER Rootkit Detector and Remover Execution

sigma HIGH SigmaHQ
imProcessCreate
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at SigmaHQ →
Retrieved: 2026-05-08T23:00:01Z · Confidence: medium

Hunt Hypothesis

Detects the execution GMER tool based on image and hash fields.

Detection Rule

Sigma (Original)

title: HackTool - GMER Rootkit Detector and Remover Execution
id: 9082ff1f-88ab-4678-a3cc-5bcff99fc74d
status: test
description: Detects the execution GMER tool based on image and hash fields.
references:
    - http://www.gmer.net/
author: Nasreddine Bencherchali (Nextron Systems)
date: 2022-10-05
modified: 2024-11-23
tags:
    - attack.stealth
logsource:
    category: process_creation
    product: windows
detection:
    selection_img:
        Image|endswith: '\gmer.exe'
    selection_sysmon_hash:
        Hashes|contains:
            - 'MD5=E9DC058440D321AA17D0600B3CA0AB04'
            - 'SHA1=539C228B6B332F5AA523E5CE358C16647D8BBE57'
            - 'SHA256=E8A3E804A96C716A3E9B69195DB6FFB0D33E2433AF871E4D4E1EAB3097237173'
    condition: 1 of selection_*
falsepositives:
    - Unlikely
level: high

KQL (Azure Sentinel)

imProcessCreate
| where TargetProcessName endswith "\\gmer.exe" or (TargetProcessMD5 startswith "E9DC058440D321AA17D0600B3CA0AB04" or TargetProcessSHA1 startswith "539C228B6B332F5AA523E5CE358C16647D8BBE57" or TargetProcessSHA256 startswith "E8A3E804A96C716A3E9B69195DB6FFB0D33E2433AF871E4D4E1EAB3097237173")

Required Data Sources

Sentinel TableNotes
imProcessCreateEnsure this data connector is enabled

False Positive Guidance

References

Original source: https://github.com/SigmaHQ/sigma/blob/master/rules/windows/process_creation/proc_creation_win_hktl_gmer.yml