← Back to SOC feed Coverage →

Notepad Password Files Discovery

sigma LOW SigmaHQ
T1083
imProcessCreate
credential-theft
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at SigmaHQ →
Retrieved: 2026-05-11T23:00:00Z · Confidence: low

Hunt Hypothesis

Detects the execution of Notepad to open a file that has the string “password” which may indicate unauthorized access to credentials or suspicious activity.

Detection Rule

Sigma (Original)

title: Notepad Password Files Discovery
id: 3b4e950b-a3ea-44d3-877e-432071990709
status: experimental
description: Detects the execution of Notepad to open a file that has the string "password" which may indicate unauthorized access to credentials or suspicious activity.
references:
    - https://thedfirreport.com/2025/02/24/confluence-exploit-leads-to-lockbit-ransomware/
    - https://intel.thedfirreport.com/eventReports/view/57  # Private Report
author: 'The DFIR Report'
tags:
    - attack.discovery
    - attack.t1083
date: 2025-02-21
logsource:
    product: windows
    category: process_creation
detection:
    selection:
        ParentImage|endswith: '\explorer.exe'
        Image|endswith: '\notepad.exe'
        CommandLine|endswith:
        # Note: Commandline to contain a file with the string password and a specific extension
            - 'password*.txt'
            - 'password*.csv'
            - 'password*.doc'
            - 'password*.xls'
    condition: selection
falsepositives:
    - Legitimate use of opening files from remote hosts by administrators or users. However, storing passwords in text readable format could potentially be a violation of the organization's policy. Any match should be investigated further.
level: low

KQL (Azure Sentinel)

imProcessCreate
| where (ParentProcessName endswith "\\explorer.exe" or ActingProcessName endswith "\\explorer.exe") and TargetProcessName endswith "\\notepad.exe" and ((TargetProcessCommandLine contains "password" and TargetProcessCommandLine contains ".txt") or (TargetProcessCommandLine contains "password" and TargetProcessCommandLine contains ".csv") or (TargetProcessCommandLine contains "password" and TargetProcessCommandLine contains ".doc") or (TargetProcessCommandLine contains "password" and TargetProcessCommandLine contains ".xls"))

Required Data Sources

Sentinel TableNotes
imProcessCreateEnsure this data connector is enabled

False Positive Guidance

MITRE ATT&CK Context

References

Original source: https://github.com/SigmaHQ/sigma/blob/master/rules/windows/process_creation/proc_creation_win_notepad_local_passwd_discovery.yml