← Back to SOC feed Coverage →

NotOnboarded Devices by DeviceName Prefix

kql MEDIUM Azure-Sentinel
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-08T23:00:01Z · Confidence: medium

Hunt Hypothesis

Devices with a specific name prefix that are not onboarded may indicate the presence of rogue or unmanaged endpoints that could be used as entry points for adversaries. Proactively hunting for such devices in Azure Sentinel helps identify potential security gaps and reduces the risk of unauthorized access to the network.

KQL Query

//
let Onboarded = "Onboarded";
let DeviceNamePrefix = "minint";
DeviceInfo
| summarize arg_max(Timestamp, *) by DeviceId
| where OnboardingStatus != "Onboarded"
| where DeviceName startswith DeviceNamePrefix

Analytic Rule Definition

id: 6ed94608-316e-4a2d-85dd-91fc9294749e
name: NotOnboarded Devices by DeviceName Prefix
description: |
  This query searches for not onboarded devices with a specific prefix
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceInfo
tactics: []
relevantTechniques: []
query: |
  //
  let Onboarded = "Onboarded";
  let DeviceNamePrefix = "minint";
  DeviceInfo
  | summarize arg_max(Timestamp, *) by DeviceId
  | where OnboardingStatus != "Onboarded"
  | where DeviceName startswith DeviceNamePrefix

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Device Inventory/NotOnboarded Devices by DeviceName Prefix.yaml