← Back to SOC feed Coverage →

Post Delivery Events over time

kql MEDIUM Azure-Sentinel
T1566
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-19T23:00:00Z · Confidence: medium

Hunt Hypothesis

Adversaries may use post delivery events to exfiltrate data or maintain persistence by leveraging zero-hour auto purge mechanisms. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify potential data exfiltration or persistence tactics that evade traditional detection methods.

KQL Query

let TimeStart = startofday(ago(30d));
let TimeEnd = startofday(now());
EmailPostDeliveryEvents
| where Timestamp >= TimeStart
| where ActionType has "ZAP"
| make-series ZappedEmails = count() default = 0 on Timestamp from TimeStart to TimeEnd step 1d
| render timechart

Analytic Rule Definition

id: c10b22a0-6021-46f9-bdaf-05bf2350a554
name: Post Delivery Events over time
description: |
  This query visualises the daily amount of emails that had a post delivery action from zero-hour auto purge.
description-detailed: |
  This query visualises the daily amount of emails that had a post delivery action from zero-hour auto purge in Defender for Office 365
requiredDataConnectors:
  - connectorId: MicrosoftThreatProtection
    dataTypes:
      - EmailPostDeliveryEvents
tactics:
  - InitialAccess
relevantTechniques:
  - T1566
query: |
  let TimeStart = startofday(ago(30d));
  let TimeEnd = startofday(now());
  EmailPostDeliveryEvents
  | where Timestamp >= TimeStart
  | where ActionType has "ZAP"
  | make-series ZappedEmails = count() default = 0 on Timestamp from TimeStart to TimeEnd step 1d
  | render timechart
version: 1.0.0

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Email and Collaboration Queries/ZAP/Post Delivery Events over time.yaml