← Back to SOC feed Coverage →

Potential Homoglyph Attack Using Lookalike Characters

sigma MEDIUM SigmaHQ
T1036T1036.003
imProcessCreate
evasion
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at SigmaHQ →
Retrieved: 2026-05-21T11:00:00Z · Confidence: medium

Hunt Hypothesis

Detects the presence of unicode characters which are homoglyphs, or identical in appearance, to ASCII letter characters. This is used as an obfuscation and masquerading techniques. Only “perfect” homo

Detection Rule

Sigma (Original)

title: Potential Homoglyph Attack Using Lookalike Characters
id: 32e280f1-8ad4-46ef-9e80-910657611fbc
status: test
description: |
    Detects the presence of unicode characters which are homoglyphs, or identical in appearance, to ASCII letter characters.
    This is used as an obfuscation and masquerading techniques. Only "perfect" homoglyphs are included; these are characters that
    are indistinguishable from ASCII characters and thus may make excellent candidates for homoglyph attack characters.
references:
    - https://redcanary.com/threat-detection-report/threats/socgholish/#threat-socgholish
    - http://www.irongeek.com/homoglyph-attack-generator.php
author: Micah Babinski, @micahbabinski
date: 2023-05-07
tags:
    - attack.stealth
    - attack.t1036
    - attack.t1036.003
logsource:
    category: process_creation
    product: windows
detection:
    selection_upper:
        CommandLine|contains:
            - "\u0410" # А/A
            - "\u0412" # В/B
            - "\u0415" # Е/E
            - "\u041a" # К/K
            - "\u041c" # М/M
            - "\u041d" # Н/H
            - "\u041e" # О/O
            - "\u0420" # Р/P
            - "\u0421" # С/C
            - "\u0422" # Т/T
            - "\u0425" # Х/X
            - "\u0405" # Ѕ/S
            - "\u0406" # І/I
            - "\u0408" # Ј/J
            - "\u04ae" # Ү/Y
            - "\u04c0" # Ӏ/I
            - "\u050C" # Ԍ/G
            - "\u051a" # Ԛ/Q
            - "\u051c" # Ԝ/W
            - "\u0391" # Α/A
            - "\u0392" # Β/B
            - "\u0395" # Ε/E
            - "\u0396" # Ζ/Z
            - "\u0397" # Η/H
            - "\u0399" # Ι/I
            - "\u039a" # Κ/K
            - "\u039c" # Μ/M
            - "\u039d" # Ν/N
            - "\u039f" # Ο/O
            - "\u03a1" # Ρ/P
            - "\u03a4" # Τ/T
            - "\u03a5" # Υ/Y
            - "\u03a7" # Χ/X
    selection_lower:
        CommandLine|contains:
            - "\u0430" # а/a
            - "\u0435" # е/e
            - "\u043e" # о/o
            - "\u0440" # р/p
            - "\u0441" # с/c
            - "\u0445" # х/x
            - "\u0455" # ѕ/s
            - "\u0456" # і/i
            - "\u04cf" # ӏ/l
            - "\u0458" # ј/j
            - "\u04bb" # һ/h
            - "\u0501" # ԁ/d
            - "\u051b" # ԛ/q
            - "\u051d" # ԝ/w
            - "\u03bf" # ο/o
    condition: 1 of selection_*
falsepositives:
    - Commandlines with legitimate Cyrillic text; will likely require tuning (or not be usable) in countries where these alphabets are in use.
level: medium

KQL (Azure Sentinel)

imProcessCreate
| where (TargetProcessCommandLine contains "А" or TargetProcessCommandLine contains "В" or TargetProcessCommandLine contains "Е" or TargetProcessCommandLine contains "К" or TargetProcessCommandLine contains "М" or TargetProcessCommandLine contains "Н" or TargetProcessCommandLine contains "О" or TargetProcessCommandLine contains "Р" or TargetProcessCommandLine contains "С" or TargetProcessCommandLine contains "Т" or TargetProcessCommandLine contains "Х" or TargetProcessCommandLine contains "Ѕ" or TargetProcessCommandLine contains "І" or TargetProcessCommandLine contains "Ј" or TargetProcessCommandLine contains "Ү" or TargetProcessCommandLine contains "Ӏ" or TargetProcessCommandLine contains "Ԍ" or TargetProcessCommandLine contains "Ԛ" or TargetProcessCommandLine contains "Ԝ" or TargetProcessCommandLine contains "Α" or TargetProcessCommandLine contains "Β" or TargetProcessCommandLine contains "Ε" or TargetProcessCommandLine contains "Ζ" or TargetProcessCommandLine contains "Η" or TargetProcessCommandLine contains "Ι" or TargetProcessCommandLine contains "Κ" or TargetProcessCommandLine contains "Μ" or TargetProcessCommandLine contains "Ν" or TargetProcessCommandLine contains "Ο" or TargetProcessCommandLine contains "Ρ" or TargetProcessCommandLine contains "Τ" or TargetProcessCommandLine contains "Υ" or TargetProcessCommandLine contains "Χ") or (TargetProcessCommandLine contains "а" or TargetProcessCommandLine contains "е" or TargetProcessCommandLine contains "о" or TargetProcessCommandLine contains "р" or TargetProcessCommandLine contains "с" or TargetProcessCommandLine contains "х" or TargetProcessCommandLine contains "ѕ" or TargetProcessCommandLine contains "і" or TargetProcessCommandLine contains "ӏ" or TargetProcessCommandLine contains "ј" or TargetProcessCommandLine contains "һ" or TargetProcessCommandLine contains "ԁ" or TargetProcessCommandLine contains "ԛ" or TargetProcessCommandLine contains "ԝ" or TargetProcessCommandLine contains "ο")

Required Data Sources

Sentinel TableNotes
imProcessCreateEnsure this data connector is enabled

False Positive Guidance

MITRE ATT&CK Context

References

Original source: https://github.com/SigmaHQ/sigma/blob/master/rules/windows/process_creation/proc_creation_win_susp_homoglyph_cyrillic_lookalikes.yml