← Back to SOC feed Coverage →

Process Creation Using Sysnative Folder

sigma MEDIUM SigmaHQ
T1055
imProcessCreate
cobalt-strike
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at SigmaHQ →
Retrieved: 2026-05-22T11:00:00Z · Confidence: medium

Hunt Hypothesis

Detects process creation events that use the Sysnative folder (common for CobaltStrike spawns)

Detection Rule

Sigma (Original)

title: Process Creation Using Sysnative Folder
id: 3c1b5fb0-c72f-45ba-abd1-4d4c353144ab
status: test
description: Detects process creation events that use the Sysnative folder (common for CobaltStrike spawns)
references:
    - https://thedfirreport.com/2021/08/29/cobalt-strike-a-defenders-guide/
author: Max Altgelt (Nextron Systems)
date: 2022-08-23
modified: 2025-10-08
tags:
    - attack.privilege-escalation
    - attack.stealth
    - attack.t1055
logsource:
    category: process_creation
    product: windows
detection:
    selection:
        - CommandLine|contains: ':\Windows\Sysnative\'
        - Image|contains: ':\Windows\Sysnative\'
    filter_main_ngen:
        Image|contains:
            - 'C:\Windows\Microsoft.NET\Framework64\v'
            - 'C:\Windows\Microsoft.NET\Framework\v'
            - 'C:\Windows\Microsoft.NET\FrameworkArm\v'
            - 'C:\Windows\Microsoft.NET\FrameworkArm64\v'
        Image|endswith: '\ngen.exe'
        CommandLine|contains: 'install'
    filter_optional_xampp:
        CommandLine|contains|all:
            - '"C:\Windows\sysnative\cmd.exe"'
            - '\xampp\'
            - '\catalina_start.bat'
    condition: selection and not 1 of filter_main_* and not 1 of filter_optional_*
falsepositives:
    - Unknown
level: medium

KQL (Azure Sentinel)

imProcessCreate
| where (TargetProcessCommandLine contains ":\\Windows\\Sysnative\\" or TargetProcessName contains ":\\Windows\\Sysnative\\") and (not(((TargetProcessName contains "C:\\Windows\\Microsoft.NET\\Framework64\\v" or TargetProcessName contains "C:\\Windows\\Microsoft.NET\\Framework\\v" or TargetProcessName contains "C:\\Windows\\Microsoft.NET\\FrameworkArm\\v" or TargetProcessName contains "C:\\Windows\\Microsoft.NET\\FrameworkArm64\\v") and TargetProcessName endswith "\\ngen.exe" and TargetProcessCommandLine contains "install"))) and (not((TargetProcessCommandLine contains "\"C:\\Windows\\sysnative\\cmd.exe\"" and TargetProcessCommandLine contains "\\xampp\\" and TargetProcessCommandLine contains "\\catalina_start.bat")))

Required Data Sources

Sentinel TableNotes
imProcessCreateEnsure this data connector is enabled

False Positive Guidance

MITRE ATT&CK Context

References

Original source: https://github.com/SigmaHQ/sigma/blob/master/rules/windows/process_creation/proc_creation_win_susp_sysnative.yml