← Back to SOC feed Coverage →

robbinhood-driver

kql MEDIUM Azure-Sentinel
DeviceFileEvents
backdoorevasionexploithuntingmicrosoftofficialransomware
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-07T11:00:00Z · Confidence: medium

Hunt Hypothesis

The hunt hypothesis detects potential ransomware activity associated with the Robbinhood ransomware variant, specifically targeting healthcare and critical infrastructure systems. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify and mitigate ransomware threats before they cause significant operational disruption.

KQL Query

DeviceFileEvents
| where Timestamp > ago(7d)
| where SHA1 in('0b15b5cc64caf0c6ad9bd759eb35383b1f718edf3d7ab4cd912d0d8c1826edf8',
'31f4cfb4c71da44120752721103a16512444c13c2ac2d857a7e6f13cb679b427')

Analytic Rule Definition

id: cd718abb-96e4-436e-9a6c-63c09d40cc5c
name: robbinhood-driver
description: |
  This query was originally published in the threat analytics report, Ransomware continues to hit healthcare, critical services. There is also a related blog.
  Robbinhood is ransomware that has been involved in several high-profile incidents, including a 2019 attack on the city of Baltimore, Maryland. Robbinhood operators often employ a distinctive defense evasion technique, where they load a vulnerable driver on to a target and exploit it, in order to turn off security software -- essentially using the driver as malware.
  The following query detects if a device contains the vulnerable drivers. These are often, but not always, implanted on the target by operators seeking to use this technique to turn off security software.
  For a query that detects a later stage of this technique, see Detect security evasion related to the Robbinhood ransomware campaign.
  References:
  https://www.microsoft.com/security/blog/2020/04/28/ransomware-groups-continue-to-target-healthcare-critical-services-heres-how-to-reduce-risk/
  https://www.microsoft.com/wdsi/threats/malware-encyclopedia-description?Name=Ransom:Win32/Robinhood.A&ThreatID=2147735370
  https://www.nytimes.com/2019/05/22/us/baltimore-ransomware.html
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceFileEvents
tactics:
- Execution
- Defense evasion
query: |
  DeviceFileEvents
  | where Timestamp > ago(7d)
  | where SHA1 in('0b15b5cc64caf0c6ad9bd759eb35383b1f718edf3d7ab4cd912d0d8c1826edf8',
  '31f4cfb4c71da44120752721103a16512444c13c2ac2d857a7e6f13cb679b427')

Required Data Sources

Sentinel TableNotes
DeviceFileEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Campaigns/robbinhood-driver.yaml