← Back to SOC feed Coverage →

Rundll32 Execution Without CommandLine Parameters

sigma HIGH SigmaHQ
T1202
imProcessCreate
cobalt-strike
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at SigmaHQ →
Retrieved: 2026-05-19T11:00:00Z · Confidence: medium

Hunt Hypothesis

Detects suspicious start of rundll32.exe without any parameters as found in CobaltStrike beacon activity

Detection Rule

Sigma (Original)

title: Rundll32 Execution Without CommandLine Parameters
id: 1775e15e-b61b-4d14-a1a3-80981298085a
status: test
description: Detects suspicious start of rundll32.exe without any parameters as found in CobaltStrike beacon activity
references:
    - https://www.cobaltstrike.com/help-opsec
    - https://twitter.com/ber_m1ng/status/1397948048135778309
author: Florian Roth (Nextron Systems)
date: 2021-05-27
modified: 2023-08-31
tags:
    - attack.stealth
    - attack.t1202
logsource:
    category: process_creation
    product: windows
detection:
    selection:
        CommandLine|endswith:
            - '\rundll32.exe'
            - '\rundll32.exe"'
            - '\rundll32'
    filter:
        ParentImage|contains:
            - '\AppData\Local\'
            - '\Microsoft\Edge\'
    condition: selection and not filter
falsepositives:
    - Possible but rare
level: high

KQL (Azure Sentinel)

imProcessCreate
| where (TargetProcessCommandLine endswith "\\rundll32.exe" or TargetProcessCommandLine endswith "\\rundll32.exe\"" or TargetProcessCommandLine endswith "\\rundll32") and (not(((ParentProcessName contains "\\AppData\\Local\\" or ParentProcessName contains "\\Microsoft\\Edge\\") or (ActingProcessName contains "\\AppData\\Local\\" or ActingProcessName contains "\\Microsoft\\Edge\\"))))

Required Data Sources

Sentinel TableNotes
imProcessCreateEnsure this data connector is enabled

False Positive Guidance

MITRE ATT&CK Context

References

Original source: https://github.com/SigmaHQ/sigma/blob/master/rules/windows/process_creation/proc_creation_win_rundll32_no_params.yml