← Back to SOC feed Coverage →

Suspicious Child Process of AspNetCompiler

sigma HIGH SigmaHQ
T1127
imProcessCreate
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at SigmaHQ →
Retrieved: 2026-05-06T11:00:00Z · Confidence: medium

Hunt Hypothesis

Detects potentially suspicious child processes of “aspnet_compiler.exe”.

Detection Rule

Sigma (Original)

title: Suspicious Child Process of AspNetCompiler
id: 9ccba514-7cb6-4c5c-b377-700758f2f120 # SuspChild
related:
    - id: 4c7f49ee-2638-43bb-b85b-ce676c30b260 # TMP File
      type: similar
    - id: 9f50fe98-fe5c-4a2d-86c7-fad7f63ed622 # Susp Paths
      type: similar
    - id: a01b8329-5953-4f73-ae2d-aa01e1f35f00 # Exec
      type: similar
status: test
description: Detects potentially suspicious child processes of "aspnet_compiler.exe".
references:
    - https://lolbas-project.github.io/lolbas/Binaries/Aspnet_Compiler/
    - https://ijustwannared.team/2020/08/01/the-curious-case-of-aspnet_compiler-exe/
author: Nasreddine Bencherchali (Nextron Systems)
date: 2023-08-14
tags:
    - attack.execution
    - attack.stealth
    - attack.t1127
logsource:
    category: process_creation
    product: windows
detection:
    selection_parent:
        ParentImage|endswith: '\aspnet_compiler.exe'
    selection_child:
        # Note: add other potential suspicious child processes and paths
        - Image|endswith:
              - '\calc.exe'
              - '\notepad.exe'
        - Image|contains:
              - '\Users\Public\'
              - '\AppData\Local\Temp\'
              - '\AppData\Local\Roaming\'
              - ':\Temp\'
              - ':\Windows\Temp\'
              - ':\Windows\System32\Tasks\'
              - ':\Windows\Tasks\'
    condition: all of selection_*
falsepositives:
    - Unknown
level: high

KQL (Azure Sentinel)

imProcessCreate
| where (ParentProcessName endswith "\\aspnet_compiler.exe" or ActingProcessName endswith "\\aspnet_compiler.exe") and ((TargetProcessName endswith "\\calc.exe" or TargetProcessName endswith "\\notepad.exe") or (TargetProcessName contains "\\Users\\Public\\" or TargetProcessName contains "\\AppData\\Local\\Temp\\" or TargetProcessName contains "\\AppData\\Local\\Roaming\\" or TargetProcessName contains ":\\Temp\\" or TargetProcessName contains ":\\Windows\\Temp\\" or TargetProcessName contains ":\\Windows\\System32\\Tasks\\" or TargetProcessName contains ":\\Windows\\Tasks\\"))

Required Data Sources

Sentinel TableNotes
imProcessCreateEnsure this data connector is enabled

False Positive Guidance

MITRE ATT&CK Context

References

Original source: https://github.com/SigmaHQ/sigma/blob/master/rules/windows/process_creation/proc_creation_win_aspnet_compiler_susp_child_process.yml