← Back to SOC feed Coverage →

Suspicious Registry Keys

kql MEDIUM Azure-Sentinel
DeviceRegistryEvents
huntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-06T11:00:00Z · Confidence: medium

Hunt Hypothesis

The Suspicious Registry Keys rule detects potential adversary behavior involving the modification or creation of registry keys associated with ZLoader malware delivery, which could indicate a compromised system. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify and mitigate early-stage malware infections that may evade traditional detection methods.

KQL Query

DeviceRegistryEvents
| where RegistryValueData in('Flyintellect Inc.', 'Datalyst ou')

Analytic Rule Definition

id: fab0fc37-d74a-43b6-9f13-d517b9cbcb14
name: Suspicious Registry Keys
description: |
  ZLoader was delivered in a campaign in late summer 2021 using malvertising to download malicious .msi files onto affected machines. This campaign was originally tweeted by @MsftSecIntel on Twitter.
  In this campaign, the malicious .msi files create registry keys that use that attacker-created comapny names.
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceRegistryEvents
tactics:
- Persistence
query: |
  DeviceRegistryEvents
  | where RegistryValueData in('Flyintellect Inc.', 'Datalyst ou')

Required Data Sources

Sentinel TableNotes
DeviceRegistryEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Campaigns/ZLoader/Suspicious Registry Keys.yaml