← Back to SOC feed Coverage →

Suspicious Tomcat Confluence Process Launch

kql MEDIUM Azure-Sentinel
T1203
DeviceProcessEvents
exploithuntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-21T23:00:01Z · Confidence: medium

Hunt Hypothesis

The query checks for suspicious Tomcat process launches associated with likely exploitation of Confluence - CVE-2022-26134 Read more here:. https://confluence.atlassian.com/doc/confluence-security-adv

KQL Query

DeviceProcessEvents
| where InitiatingProcessFileName hasprefix "tomcat" and InitiatingProcessCommandLine has "confluence"
| where (ProcessCommandLine has_any("certutil", "whoami", "nltest", " dir ", "curl", "ifconfig", "cat ", "net user",
"net time /domain","tasklist","-c ls","ipconfig","arp","ping","net view","net group","netstat", "wmic datafile"))
or (FileName =~ "powershell.exe" and ProcessCommandLine hasprefix "-e") 

Analytic Rule Definition

id: 500e4cf1-9c25-4dfa-88f1-a23d95407e35
name: Suspicious Tomcat Confluence Process Launch
description: |
  The query checks for suspicious Tomcat process launches associated with likely exploitation of Confluence - CVE-2022-26134
  Read more here:.
  https://confluence.atlassian.com/doc/confluence-security-advisory-2022-06-02-1130377146.html
  https://nvd.nist.gov/vuln/detail/CVE-2022-26134
  Tags: #exploit #CVE-2022-26134
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - DeviceProcessEvents
tactics:
  - Execution
  - Privilege Escalation
relevantTechniques:
  - T1203
query: |
  DeviceProcessEvents
  | where InitiatingProcessFileName hasprefix "tomcat" and InitiatingProcessCommandLine has "confluence"
  | where (ProcessCommandLine has_any("certutil", "whoami", "nltest", " dir ", "curl", "ifconfig", "cat ", "net user",
  "net time /domain","tasklist","-c ls","ipconfig","arp","ping","net view","net group","netstat", "wmic datafile"))
  or (FileName =~ "powershell.exe" and ProcessCommandLine hasprefix "-e") 

Required Data Sources

Sentinel TableNotes
DeviceProcessEventsEnsure this data connector is enabled

False Positive Guidance

MITRE ATT&CK Context

References

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Exploits/CVE-2022-26134-Confluence.yaml