← Back to SOC feed Coverage →

Threat actor Phosphorus masquerading as conference organizers (1)

kql MEDIUM Azure-Sentinel
EmailEvents
backdoorhuntingmicrosoftofficial
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at Azure-Sentinel →
Retrieved: 2026-05-06T11:00:00Z · Confidence: medium

Hunt Hypothesis

Threat actor Phosphorus is using compromised email accounts of conference organizers to send phishing emails with malicious attachments, leveraging social engineering to target attendees. SOC teams should proactively hunt for this behavior in Azure Sentinel to detect and mitigate Phosphorus campaign activity early, preventing potential data exfiltration and lateral movement.

KQL Query

//Filter for emails that were delivered check the FinalEmailAction to see if there was policy applied on this email
let MaliciousSenders = dynamic(["t20saudiarabia@outlook.sa", "t20saudiarabia@hotmail.com", "t20saudiarabia@gmail.com", "munichconference@outlook.com",  
"munichconference@outlook.de", "munichconference1962@gmail.com"]);
EmailEvents
| where SenderFromAddress  in~ (MaliciousSenders) and DeliveryAction == "Delivered"

Analytic Rule Definition

id: 32f927f2-b1f3-441b-8885-bd66404e091d
name: Threat actor Phosphorus masquerading as conference organizers (1)
description: |
  Identify prior activity from this campaign using IOCs shared by Microsoft's Threat Intelligence Center, or MSTIC.
  Read more: https://blogs.microsoft.com/on-the-issues/2020/10/28/cyberattacks-phosphorus-t20-munich-security-conference/
requiredDataConnectors:
- connectorId: MicrosoftThreatProtection
  dataTypes:
  - EmailEvents
tactics:
- Initial access
query: |
  //Filter for emails that were delivered check the FinalEmailAction to see if there was policy applied on this email
  let MaliciousSenders = dynamic(["t20saudiarabia@outlook.sa", "t20saudiarabia@hotmail.com", "t20saudiarabia@gmail.com", "munichconference@outlook.com",  
  "munichconference@outlook.de", "munichconference1962@gmail.com"]);
  EmailEvents
  | where SenderFromAddress  in~ (MaliciousSenders) and DeliveryAction == "Delivered"

Required Data Sources

Sentinel TableNotes
EmailEventsEnsure this data connector is enabled

MITRE ATT&CK Context

References

False Positive Guidance

Original source: https://github.com/Azure/Azure-Sentinel/blob/main/Hunting Queries/Microsoft 365 Defender/Campaigns/Threat actor Phosphorus masquerading as conference organizers (1).yaml