This hunt detects adversary activity by correlating network and endpoint telemetry against specific Indicators of Compromise (IOCs) linked to the Aisuru threat actor. Proactively hunting for these signals in Azure Sentinel is critical because early identification of Aisuru’s unique footprint enables rapid containment before lateral movement or data exfiltration occurs within the environment.
Malware Family: Aisuru Total IOCs: 23 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 165[.]22[.]191[.]159:8080 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 188[.]166[.]146[.]72:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 206[.]189[.]127[.]191:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 139[.]59[.]178[.]162:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 164[.]90[.]172[.]4:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 178[.]128[.]173[.]150:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 134[.]122[.]68[.]91:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 164[.]90[.]234[.]119:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 167[.]71[.]54[.]89:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 138[.]68[.]169[.]201:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 178[.]128[.]36[.]32:8001 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 188[.]166[.]160[.]153:8080 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 165[.]245[.]209[.]216:8443 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 188[.]166[.]160[.]153:8443 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 134[.]209[.]176[.]36:8080 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 46[.]101[.]160[.]192:8080 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 178[.]128[.]201[.]199:8080 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 46[.]101[.]160[.]192:8443 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 165[.]232[.]112[.]16:8080 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 165[.]232[.]112[.]16:8443 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 167[.]71[.]38[.]182:34567 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 178[.]128[.]201[.]199:8443 | botnet_cc | 2026-09-01 | 100% |
| ip:port | 45[.]55[.]191[.]196:8443 | botnet_cc | 2026-09-01 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Aisuru
let malicious_ips = dynamic(["134.209.176.36", "178.128.201.199", "178.128.173.150", "165.232.112.16", "188.166.146.72", "206.189.127.191", "138.68.169.201", "46.101.160.192", "165.22.191.159", "164.90.172.4", "165.245.209.216", "167.71.54.89", "139.59.178.162", "188.166.160.153", "164.90.234.119", "45.55.191.196", "134.122.68.91", "167.71.38.182", "178.128.36.32"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["134.209.176.36", "178.128.201.199", "178.128.173.150", "165.232.112.16", "188.166.146.72", "206.189.127.191", "138.68.169.201", "46.101.160.192", "165.22.191.159", "164.90.172.4", "165.245.209.216", "167.71.54.89", "139.59.178.162", "188.166.160.153", "164.90.234.119", "45.55.191.196", "134.122.68.91", "167.71.38.182", "178.128.36.32"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios and corresponding filters for the ThreatFox: Aisuru IOCs detection rule in an enterprise environment:
Scenario: Endpoint Protection Engine Updates via Scheduled Task
MsMpEng.exe (Defender) or FalconSensorService.exe (CrowdStrike) when they are running under the system account (SYSTEM) during defined maintenance windows (e.g., 02:00–04:00 UTC). Exclude alerts where the file hash matches known EDR update hashes.Scenario: Admin Deployment of Security Policies via Group Policy
ccmexec.exe (SCCM) or IntuneManagementExtension.exe. Additionally, filter out events occurring on hosts tagged with “Security-Admin” or within the “IT-Operations” OU, as these are known sources of legitimate policy changes.Scenario: Automated Compliance Scanning by Internal Security Tools