This hunt detects adversary activity by correlating network and endpoint telemetry against fifteen specific Indicators of Compromise (IOCs) linked to the Aisuru threat actor. Proactively hunting for these signatures in Azure Sentinel is critical because Aisuru’s high-severity footprint suggests sophisticated, targeted campaigns that require immediate identification before lateral expansion occurs.
Malware Family: Aisuru Total IOCs: 15 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 132[.]243[.]199[.]3:8443 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 91[.]108[.]249[.]140:34567 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 91[.]108[.]249[.]186:34567 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 134[.]122[.]98[.]48:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 138[.]68[.]138[.]44:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 165[.]232[.]71[.]140:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 206[.]189[.]119[.]212:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 138[.]68[.]93[.]46:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 167[.]99[.]143[.]174:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 164[.]92[.]179[.]21:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 64[.]227[.]117[.]72:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 159[.]65[.]61[.]151:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 139[.]59[.]161[.]246:8001 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 91[.]108[.]249[.]140:8080 | botnet_cc | 2026-07-10 | 100% |
| ip:port | 138[.]68[.]93[.]46:34567 | botnet_cc | 2026-07-10 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Aisuru
let malicious_ips = dynamic(["167.99.143.174", "165.232.71.140", "164.92.179.21", "159.65.61.151", "206.189.119.212", "91.108.249.186", "138.68.138.44", "91.108.249.140", "134.122.98.48", "132.243.199.3", "139.59.161.246", "138.68.93.46", "64.227.117.72"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["167.99.143.174", "165.232.71.140", "164.92.179.21", "159.65.61.151", "206.189.119.212", "91.108.249.186", "138.68.138.44", "91.108.249.140", "134.122.98.48", "132.243.199.3", "139.59.161.246", "138.68.93.46", "64.227.117.72"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
Here are 4 specific false positive scenarios for the ThreatFox: Aisuru IOCs detection rule in an enterprise environment, along with suggested filters or exclusions:
Security Operations Center (SOC) Threat Intelligence Ingestion Jobs
10.50.20.0/24) or specific service accounts used for threat ingestion (e.g., svc_threat_intel_ingest). Additionally, filter out events where the destination port is 80/443 and the user agent string contains “ThreatIntel-Connector”.Endpoint Protection Policy Updates via Central Management Console
svc_epm_updater) running known management tools. Filter out alerts where the process path matches the standard installation directory of the endpoint management agent (e.g., C:\Program Files\Tanium\Agent\).Automated Vulnerability Scanning and Compliance Audits