This hunt detects adversary activity by correlating Azure Sentinel logs against 21 specific Indicators of Compromise (IOCs) linked to the Aisuru threat campaign. Proactively hunting for these IOCs is critical because it enables the SOC team to identify early-stage intrusions and potential lateral movement before they escalate into significant security incidents within the cloud environment.
Malware Family: Aisuru Total IOCs: 21 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 45[.]55[.]191[.]196:8080 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 152[.]42[.]255[.]118:8080 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 134[.]122[.]124[.]236:8001 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 45[.]55[.]191[.]196:8001 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 152[.]42[.]255[.]118:8001 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 167[.]99[.]128[.]245:8001 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 67[.]205[.]132[.]147:8001 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 174[.]138[.]30[.]59:8001 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 165[.]22[.]191[.]159:8001 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 104[.]248[.]27[.]128:8001 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 165[.]22[.]122[.]89:9034 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 165[.]22[.]191[.]159:8443 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 104[.]248[.]247[.]126:9034 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 174[.]138[.]30[.]59:8443 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 167[.]99[.]194[.]254:9035 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 104[.]248[.]27[.]128:8443 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 67[.]205[.]132[.]147:8443 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 134[.]122[.]124[.]236:8443 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 167[.]99[.]128[.]245:34567 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 152[.]42[.]255[.]118:8443 | botnet_cc | 2026-08-30 | 100% |
| ip:port | 159[.]65[.]50[.]202:8080 | botnet_cc | 2026-08-30 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Aisuru
let malicious_ips = dynamic(["167.99.194.254", "67.205.132.147", "104.248.247.126", "104.248.27.128", "159.65.50.202", "134.122.124.236", "165.22.122.89", "152.42.255.118", "167.99.128.245", "45.55.191.196", "174.138.30.59", "165.22.191.159"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["167.99.194.254", "67.205.132.147", "104.248.247.126", "104.248.27.128", "159.65.50.202", "134.122.124.236", "165.22.122.89", "152.42.255.118", "167.99.128.245", "45.55.191.196", "174.138.30.59", "165.22.191.159"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios and corresponding exclusion strategies for the ThreatFox: Aisuru IOCs detection rule in an enterprise environment:
Scenario: Enterprise Antivirus Definition Updates
C:\Program Files\CrowdStrike\FalconSensor\csagent.exe) or the destination IP range of the vendor’s update servers, excluding traffic originating from the “Update Service” scheduled task (Microsoft-Windows-Update).Scenario: Automated Backup and Archiving Jobs
vbr.exe (Veeam) and the event occurs within a defined time window (e.g., 02:00–04:00 UTC), or add the specific destination IP addresses of the cloud storage gateway to an allow-list.Scenario: Third-Party Software License Verification