This detection rule identifies adversary activity by matching network and endpoint telemetry against six specific Indicators of Compromise (IOCs) linked to the Kuiper threat campaign. A proactive hunt is essential in Azure Sentinel to rapidly uncover early-stage intrusions associated with this campaign before they escalate into broader lateral movements or data exfiltration events.
Malware Family: Kuiper Total IOCs: 6 IOC Types: sha1_hash, md5_hash, sha256_hash
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| sha1_hash | c3a0be16abf09c569acd2d61ebff4972549854d2 | payload | 2026-08-13 | 95% |
| md5_hash | a56d67f5e2f1b15b2c3864ff9501d7cc | payload | 2026-08-13 | 95% |
| sha256_hash | e2bebe7d6fcc4e9ce414fa6f2fb357a1ec517712e2d1597e25752b3616e2d650 | payload | 2026-08-13 | 95% |
| sha1_hash | 2571413368bb32f0b8eb3637b317a734978cf42b | payload | 2026-08-13 | 95% |
| md5_hash | 725368095f3e67cf813c8c442652ca97 | payload | 2026-08-13 | 95% |
| sha256_hash | bbbdcc7dc8d6ef0cdb2c72ddb0ed3858343db8705dfbd9b904a509342d6f4c12 | payload | 2026-08-13 | 95% |
// Hunt for files matching known malicious hashes
// Source: ThreatFox - Kuiper
let malicious_hashes = dynamic(["c3a0be16abf09c569acd2d61ebff4972549854d2", "a56d67f5e2f1b15b2c3864ff9501d7cc", "e2bebe7d6fcc4e9ce414fa6f2fb357a1ec517712e2d1597e25752b3616e2d650", "2571413368bb32f0b8eb3637b317a734978cf42b", "725368095f3e67cf813c8c442652ca97", "bbbdcc7dc8d6ef0cdb2c72ddb0ed3858343db8705dfbd9b904a509342d6f4c12"]);
DeviceFileEvents
| where SHA256 in (malicious_hashes) or SHA1 in (malicious_hashes) or MD5 in (malicious_hashes)
| project Timestamp, DeviceName, FileName, FolderPath, SHA256, InitiatingProcessFileName
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
DeviceFileEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios and corresponding filters for the ThreatFox: Kuiper IOCs detection rule in an enterprise environment:
Security Information and Event Management (SIEM) Ingestion Jobs
02:00 - 04:00 UTC).Endpoint Detection and Response (EDR) Cloud Connectivity
Destination Port 443 where Source Host Group = 'EDR_Agents').Automated Vulnerability Scanning Workflows