This hunt targets the Mozi botnet, a prevalent Linux-based malware family that establishes persistent backdoor access and facilitates command-and-control communication through known IP addresses and file paths. Proactively hunting for these IOCs in Azure Sentinel allows the SOC to identify compromised virtual machines or containers before the botnet can be leveraged for DDoS attacks or lateral movement within the cloud infrastructure.
Malware Family: Mozi Total IOCs: 8 IOC Types: url
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| url | hxxp://223[.]123[.]43[.]33:45481/Mozi.m | payload_delivery | 2026-09-03 | 75% |
| url | hxxp://27[.]77[.]246[.]66:44109/Mozi.m | payload_delivery | 2026-09-03 | 75% |
| url | hxxp://221[.]15[.]20[.]208:44679/Mozi.m | payload_delivery | 2026-09-03 | 75% |
| url | hxxp://223[.]123[.]71[.]42:37337/Mozi.m | payload_delivery | 2026-09-03 | 75% |
| url | hxxp://153[.]117[.]9[.]176:46305/Mozi.m | payload_delivery | 2026-09-03 | 75% |
| url | hxxp://160[.]30[.]142[.]218:44307/Mozi.m | payload_delivery | 2026-09-03 | 75% |
| url | hxxp://137[.]59[.]218[.]242:50617/Mozi.m | payload_delivery | 2026-09-03 | 75% |
| url | hxxp://119[.]30[.]117[.]159:46505/Mozi.m | payload_delivery | 2026-09-03 | 75% |
// Hunt for access to known malicious URLs
// Source: ThreatFox - Mozi
let malicious_urls = dynamic(["http://223.123.43.33:45481/Mozi.m", "http://27.77.246.66:44109/Mozi.m", "http://221.15.20.208:44679/Mozi.m", "http://223.123.71.42:37337/Mozi.m", "http://153.117.9.176:46305/Mozi.m", "http://160.30.142.218:44307/Mozi.m", "http://137.59.218.242:50617/Mozi.m", "http://119.30.117.159:46505/Mozi.m"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
UrlClickEvents | Ensure this data connector is enabled |
C:\ProgramData\BackupStaging). If the backup agent writes a file with a name or hash matching a Mozi IOC, it can trigger the rule.
VeeamBackup.exe, cvpp.exe (Commvault), or rubik-agent.exe, and restrict the file path to standard backup staging directories like C:\ProgramData\Veeam\ or D:\BackupStaging\.jenkins-svc, ci-runner, or build-agent, and limit the file path to workspace directories such as C:\Jenkins\workspace\ or /home/runner/work/.