← Back to SOC feed Coverage →

ThreatFox: KongTuke IOCs

ioc-hunt HIGH ThreatFox
DnsEventsUrlClickEvents
iocjs-kongtukethreatfox
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at ThreatFox →
Retrieved: 2026-05-21T11:00:00Z · Confidence: high

Hunt Hypothesis

The ThreatFox: KongTuke IOCs rule detects potential adversary activity linked to the KongTuke threat group, which is associated with high-severity malicious campaigns. SOC teams should proactively hunt for these IOCs in Azure Sentinel to identify and mitigate early-stage compromises before lateral movement and data exfiltration occur.

IOC Summary

Malware Family: KongTuke Total IOCs: 8 IOC Types: url, domain

TypeValueThreat TypeFirst SeenConfidence
urlhxxps://ackerkann.lol/api/v1/sessionpayload_delivery2026-05-21100%
urlhxxps://ackerkann.lol/api/v1/verifypayload_delivery2026-05-21100%
domainackerkann.lolpayload_delivery2026-05-21100%
urlhxxps://ackerkann.lol/file.jspayload_delivery2026-05-21100%
urlhxxps://lolfler.lol/api/v1/sessionpayload_delivery2026-05-21100%
urlhxxps://lolfler.lol/api/v1/verifypayload_delivery2026-05-21100%
domainlolfler.lolpayload_delivery2026-05-21100%
urlhxxps://lolfler.lol/file.jspayload_delivery2026-05-21100%

KQL: Domain Hunt

// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - KongTuke
let malicious_domains = dynamic(["ackerkann.lol", "lolfler.lol"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc

KQL: Url Hunt

// Hunt for access to known malicious URLs
// Source: ThreatFox - KongTuke
let malicious_urls = dynamic(["https://ackerkann.lol/api/v1/session", "https://ackerkann.lol/api/v1/verify", "https://ackerkann.lol/file.js", "https://lolfler.lol/api/v1/session", "https://lolfler.lol/api/v1/verify", "https://lolfler.lol/file.js"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc

Required Data Sources

Sentinel TableNotes
DnsEventsEnsure this data connector is enabled
UrlClickEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://threatfox.abuse.ch/browse/malware/js.kongtuke/