← Back to SOC feed Coverage →

ThreatFox: KongTuke IOCs

ioc-hunt HIGH ThreatFox
DeviceFileEventsDnsEventsUrlClickEvents
iocjs-kongtukethreatfox
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at ThreatFox →
Retrieved: 2026-05-18T23:00:00Z · Confidence: high

Hunt Hypothesis

The ThreatFox: KongTuke IOCs rule detects potential adversary activity associated with the KongTuke threat group, which is linked to malicious network traffic and data exfiltration. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify and mitigate advanced persistent threats leveraging these IOCs before significant damage occurs.

IOC Summary

Malware Family: KongTuke Total IOCs: 6 IOC Types: sha256_hash, url, domain

TypeValueThreat TypeFirst SeenConfidence
sha256_hashf581012ea6faaff213d79db7ea93194a423a419870d0db664b90a0db6ae4088bpayload2026-05-1890%
sha256_hash3aaae158a84409dbc3202b174005ed9acf39ca7f3785dbff07c56be928ff011fpayload2026-05-1890%
sha256_hash833a0e0ed8bc34a1af0fbb43c56f7bea2c73dde2295f4df2e2c27011d70f52fapayload2026-05-1890%
sha256_hash6d11817f510e596bb9b739dd1fddb3b1c929831b81503a4e8d7129543bf899b9payload2026-05-1890%
urlhxxps://k020e5b3g0h.com/dpayload_delivery2026-05-18100%
domaink020e5b3g0h.compayload_delivery2026-05-18100%

KQL: Domain Hunt

// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - KongTuke
let malicious_domains = dynamic(["k020e5b3g0h.com"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc

KQL: Url Hunt

// Hunt for access to known malicious URLs
// Source: ThreatFox - KongTuke
let malicious_urls = dynamic(["https://k020e5b3g0h.com/d"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc

KQL: Hash Hunt

// Hunt for files matching known malicious hashes
// Source: ThreatFox - KongTuke
let malicious_hashes = dynamic(["f581012ea6faaff213d79db7ea93194a423a419870d0db664b90a0db6ae4088b", "3aaae158a84409dbc3202b174005ed9acf39ca7f3785dbff07c56be928ff011f", "833a0e0ed8bc34a1af0fbb43c56f7bea2c73dde2295f4df2e2c27011d70f52fa", "6d11817f510e596bb9b739dd1fddb3b1c929831b81503a4e8d7129543bf899b9"]);
DeviceFileEvents
| where SHA256 in (malicious_hashes) or SHA1 in (malicious_hashes) or MD5 in (malicious_hashes)
| project Timestamp, DeviceName, FileName, FolderPath, SHA256, InitiatingProcessFileName
| order by Timestamp desc

Required Data Sources

Sentinel TableNotes
DeviceFileEventsEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled
UrlClickEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://threatfox.abuse.ch/browse/malware/js.kongtuke/