← Back to SOC feed Coverage →

ThreatFox: SmartApeSG IOCs

ioc-hunt HIGH ThreatFox
DnsEventsUrlClickEvents
iocjs-smartapesgthreatfox
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at ThreatFox →
Retrieved: 2026-05-06T11:00:00Z · Confidence: high

Hunt Hypothesis

The ThreatFox: SmartApeSG IOCs rule detects potential adversary activity linked to the SmartApeSG threat group, which is associated with malware distribution and command-and-control infrastructure. SOC teams should proactively hunt for these IOCs in Azure Sentinel to identify and mitigate early-stage compromises before lateral movement and data exfiltration occur.

IOC Summary

Malware Family: SmartApeSG Total IOCs: 5 IOC Types: domain, url

TypeValueThreat TypeFirst SeenConfidence
urlhxxps://activebridgehub.top/metrics/health-build.phppayload_delivery2026-05-06100%
domainactivebridgehub.toppayload_delivery2026-05-06100%
urlhxxps://activebridgehub.top/metrics/signup-dom.jspayload_delivery2026-05-06100%
urlhxxps://futurebuildsystem.com/yolodopayload_delivery2026-05-06100%
domainfuturebuildsystem.compayload_delivery2026-05-06100%

KQL: Domain Hunt

// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - SmartApeSG
let malicious_domains = dynamic(["activebridgehub.top", "futurebuildsystem.com"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc

KQL: Url Hunt

// Hunt for access to known malicious URLs
// Source: ThreatFox - SmartApeSG
let malicious_urls = dynamic(["https://activebridgehub.top/metrics/health-build.php", "https://activebridgehub.top/metrics/signup-dom.js", "https://futurebuildsystem.com/yolodo"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc

Required Data Sources

Sentinel TableNotes
DnsEventsEnsure this data connector is enabled
UrlClickEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://threatfox.abuse.ch/browse/malware/js.smartapesg/