← Back to SOC feed Coverage →

ThreatFox: SmartApeSG IOCs

ioc-hunt HIGH ThreatFox
DnsEventsUrlClickEvents
iocjs-smartapesgthreatfox
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at ThreatFox →
Retrieved: 2026-09-16T23:00:00Z · Confidence: high

Hunt Hypothesis

This hunt targets the presence of known SmartApeSG indicators of compromise to identify potential intrusions by this threat actor. Proactively hunting for these IOCs in Azure Sentinel is critical because SmartApeSG is associated with high-severity threats, enabling the SOC to detect and contain lateral movement or persistence mechanisms before they escalate into a full breach.

IOC Summary

Malware Family: SmartApeSG Total IOCs: 3 IOC Types: url, domain

TypeValueThreat TypeFirst SeenConfidence
urlhxxps://yewanthology.co/rate/settings-compiler.jspayload_delivery2026-09-16100%
domainlarchfable.cloudpayload_delivery2026-09-16100%
urlhxxps://larchfable.cloud/verify/api-theme.jspayload_delivery2026-09-16100%

KQL: Domain Hunt

// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - SmartApeSG
let malicious_domains = dynamic(["larchfable.cloud"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc

KQL: Url Hunt

// Hunt for access to known malicious URLs
// Source: ThreatFox - SmartApeSG
let malicious_urls = dynamic(["https://yewanthology.co/rate/settings-compiler.js", "https://larchfable.cloud/verify/api-theme.js"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc

Required Data Sources

Sentinel TableNotes
DnsEventsEnsure this data connector is enabled
UrlClickEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://threatfox.abuse.ch/browse/malware/js.smartapesg/