This hunt hypothesis targets adversaries leveraging the specific set of 14 Indicators of Compromise (IOCs) linked to the Tsundere threat actor to identify active reconnaissance or initial access attempts within the network. Proactively hunting for these signatures in Azure Sentinel is critical due to the high severity rating, enabling the SOC team to detect and contain potential Tsundere campaigns before they escalate into broader lateral movements or data exfiltration events.
Malware Family: Tsundere Total IOCs: 14 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 91[.]92[.]43[.]194:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 91[.]92[.]43[.]195:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 91[.]92[.]43[.]196:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 91[.]92[.]43[.]193:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 89[.]125[.]153[.]29:443 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 82[.]25[.]63[.]124:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 82[.]25[.]63[.]130:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 199[.]217[.]99[.]189:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 199[.]91[.]220[.]216:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 193[.]24[.]123[.]25:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 185[.]45[.]193[.]84:443 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 138[.]124[.]240[.]76:443 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 138[.]124[.]240[.]76:80 | botnet_cc | 2026-06-30 | 75% |
| ip:port | 138[.]124[.]240[.]77:80 | botnet_cc | 2026-06-30 | 75% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Tsundere
let malicious_ips = dynamic(["91.92.43.193", "82.25.63.130", "91.92.43.196", "199.91.220.216", "91.92.43.195", "89.125.153.29", "82.25.63.124", "91.92.43.194", "193.24.123.25", "185.45.193.84", "138.124.240.76", "138.124.240.77", "199.217.99.189"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["91.92.43.193", "82.25.63.130", "91.92.43.196", "199.91.220.216", "91.92.43.195", "89.125.153.29", "82.25.63.124", "91.92.43.194", "193.24.123.25", "185.45.193.84", "138.124.240.76", "138.124.240.77", "199.217.99.189"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
Here are 5 specific false positive scenarios for the ThreatFox: Tsundere IOCs detection rule, tailored for an enterprise environment:
Endpoint Protection Scanning of Quarantine Archives
C:\Program Files\CrowdStrike\fsagent.exe or MsMpEng.exe) and the file path resides within a designated “Quarantine” or “Archive” directory structure.Security Information & Event Management (SIEM) Log Ingestion
10.20.50.0/24) or where the destination port corresponds to internal SIEM ingestion services, provided the user agent string matches known security tool identifiers.Software Deployment via Configuration Management Tools