This hypothesis targets the presence of known indicators of compromise associated with the MacSync malware, which often leverages browser extensions to exfiltrate sensitive data. Proactively hunting for these IOCs in Azure Sentinel allows the SOC team to identify compromised endpoints before the adversary can establish persistent access or steal credentials.
Malware Family: MacSync Total IOCs: 7 IOC Types: domain, ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| domain | cli-desktop.com | payload_delivery | 2026-09-03 | 100% |
| domain | fern-plume.com | payload_delivery | 2026-09-03 | 100% |
| domain | node-slate.com | payload_delivery | 2026-09-03 | 100% |
| domain | jadeleap15.com | payload_delivery | 2026-09-03 | 100% |
| domain | loop-lumen.com | payload_delivery | 2026-09-03 | 100% |
| ip:port | 164[.]90[.]161[.]147:80 | payload_delivery | 2026-09-03 | 100% |
| ip:port | 164[.]90[.]161[.]147:443 | payload_delivery | 2026-09-03 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - MacSync
let malicious_ips = dynamic(["164.90.161.147"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["164.90.161.147"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - MacSync
let malicious_domains = dynamic(["cli-desktop.com", "fern-plume.com", "node-slate.com", "jadeleap15.com", "loop-lumen.com"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
\\[server]\archive, \\[server]\cold_storage, or C:\Backups\ and the action is Move or Copy rather than Create or Modify.sync_helper.dll or similar generic names), it will be written to the build workspace.
svc-jenkins, azure-devops-agent) or where the file path includes /workspace/, /build/, or /temp/.Quarantine, Isolated, or Defender\Quarantine, and the source process is a known EDR/AV agent executable.