← Back to SOC feed Coverage →

ThreatFox: Unknown malware IOCs

ioc-hunt HIGH ThreatFox
DnsEventsUrlClickEvents
iocthreatfoxunknown
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at ThreatFox →
Retrieved: 2026-08-21T11:00:00Z · Confidence: high

Hunt Hypothesis

This detection rule identifies potential unknown malware threats by monitoring five specific Indicators of Compromise (IOCs) that may signal early-stage adversary activity within the network. Proactively hunting for these IOCs in Azure Sentinel is critical to rapidly isolate and investigate novel malicious artifacts before they can establish persistence or propagate across the environment.

IOC Summary

Malware Family: Unknown malware Total IOCs: 5 IOC Types: url, domain

TypeValueThreat TypeFirst SeenConfidence
urlhxxps://193-233-126-53.sslip.io/d3f8a142c9/verification.sctpayload_delivery2026-08-2190%
urlhxxps://www.rzrms.com/payload_delivery2026-08-2190%
urlhxxps://www.tdvm4q.com/payload_delivery2026-08-2190%
domainakmuniverstall.topbotnet_cc2026-08-21100%
urlhxxps://akmuniverstall.top/backend/api/app.phpbotnet_cc2026-08-21100%

KQL: Domain Hunt

// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Unknown malware
let malicious_domains = dynamic(["akmuniverstall.top"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc

KQL: Url Hunt

// Hunt for access to known malicious URLs
// Source: ThreatFox - Unknown malware
let malicious_urls = dynamic(["https://193-233-126-53.sslip.io/d3f8a142c9/verification.sct", "https://www.rzrms.com/", "https://www.tdvm4q.com/", "https://akmuniverstall.top/backend/api/app.php"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc

Required Data Sources

Sentinel TableNotes
DnsEventsEnsure this data connector is enabled
UrlClickEventsEnsure this data connector is enabled

References

False Positive Guidance

Here are 4 specific false positive scenarios for the ThreatFox: Unknown malware IOCs rule, along with targeted filters and exclusions:

Original source: https://threatfox.abuse.ch/browse/malware/unknown/