This hunt targets adversary behavior characterized by the presence of 81 unknown malware indicators that may represent emerging threats not yet covered by existing signature-based detections. Proactively hunting for these IOCs in Azure Sentinel is critical to identify early-stage infections and reduce dwell time before adversaries can establish persistence or exfiltrate sensitive data.
Malware Family: Unknown malware Total IOCs: 81 IOC Types: ip:port, domain, url
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 103[.]215[.]81[.]156:22 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 103[.]215[.]81[.]156:81 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 103[.]142[.]147[.]18:8001 | botnet_cc | 2026-07-18 | 100% |
| domain | errjothcxmklspp.cc | payload_delivery | 2026-07-18 | 100% |
| domain | errakgrwenmjibedi.cc | payload_delivery | 2026-07-18 | 100% |
| domain | clouderrtufjcb.cc | payload_delivery | 2026-07-18 | 100% |
| ip:port | 31[.]57[.]93[.]182:7443 | botnet_cc | 2026-07-18 | 75% |
| domain | auth-id-browser.info | payload_delivery | 2026-07-18 | 100% |
| domain | babelo.pro | payload_delivery | 2026-07-18 | 100% |
| domain | baboke.pro | payload_delivery | 2026-07-18 | 100% |
| ip:port | 103[.]142[.]147[.]18:33061 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 103[.]142[.]147[.]19:8812 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 103[.]142[.]147[.]19:59517 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 103[.]142[.]147[.]19:33061 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 103[.]142[.]147[.]19:8001 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 158[.]94[.]211[.]92:443 | payload_delivery | 2026-07-18 | 100% |
| ip:port | 103[.]142[.]147[.]17:59517 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 103[.]142[.]147[.]17:33061 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 103[.]142[.]147[.]17:8812 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 111[.]229[.]144[.]163:888 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 111[.]229[.]144[.]163:18789 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 111[.]229[.]144[.]163:3306 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 208[.]87[.]201[.]226:4369 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 208[.]87[.]201[.]226:28888 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 208[.]87[.]201[.]226:5003 | botnet_cc | 2026-07-18 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Unknown malware
let malicious_ips = dynamic(["103.142.147.17", "111.229.144.163", "103.142.147.19", "151.241.100.197", "208.87.201.226", "103.215.81.156", "103.142.147.18", "152.42.185.244", "31.57.93.182", "54.196.93.40", "158.94.211.92", "192.144.211.249"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["103.142.147.17", "111.229.144.163", "103.142.147.19", "151.241.100.197", "208.87.201.226", "103.215.81.156", "103.142.147.18", "152.42.185.244", "31.57.93.182", "54.196.93.40", "158.94.211.92", "192.144.211.249"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Unknown malware
let malicious_domains = dynamic(["errjothcxmklspp.cc", "errakgrwenmjibedi.cc", "clouderrtufjcb.cc", "auth-id-browser.info", "babelo.pro", "baboke.pro", "xverikstat.us", "usalaborforhire.net", "stroinnetsata.biz", "stek-moldova.com", "sosstat.beer", "masterklass.net", "sorrystartstat1.net", "snowwhitefox.com", "smarthouseapp.com"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Unknown malware
let malicious_urls = dynamic(["https://crf.masterklass.net", "https://xverikstat.us/dl/file/", "https://xverikstat.us/ccheck", "https://xverikstat.us/cload", "https://xverikstat.us/tracker.js", "https://usalaborforhire.net/dl/file/", "https://usalaborforhire.net/ccheck", "https://usalaborforhire.net/cload", "https://usalaborforhire.net/tracker.js", "https://stroinnetsata.biz/dl/file/", "https://stroinnetsata.biz/ccheck", "https://stroinnetsata.biz/cload", "https://stroinnetsata.biz/tracker.js", "https://stek-moldova.com/dl/file/", "https://stek-moldova.com/ccheck", "https://stek-moldova.com/cload", "https://stek-moldova.com/tracker.js", "https://sosstat.beer/dl/file/", "https://sosstat.beer/ccheck", "https://sosstat.beer/cload", "https://sosstat.beer/tracker.js", "https://masterklass.net/dl/file/", "https://masterklass.net/ccheck", "https://masterklass.net/cload", "https://masterklass.net/tracker.js", "https://sorrystartstat1.net/dl/file/", "https://sorrystartstat1.net/ccheck", "https://sorrystartstat1.net/cload", "https://sorrystartstat1.net/tracker.js", "https://snowwhitefox.com/dl/file/"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Here are 4 specific false positive scenarios for the ThreatFox: Unknown malware IOCs detection rule, tailored for an enterprise environment:
Enterprise Patch Management Scans
ccmexec.exe or IvantiAgent.exe) and restrict the alert to only trigger if the User Account is not a local system account (e.g., exclude NT AUTHORITY\SYSTEM).Third-Party Application Updates via Silent Installers
.msi or .exe) to the %TEMP% directory, which contain hash values and network behaviors that align with the “Unknown malware” IOCs before the final signature is updated in ThreatFox.C:\ProgramData\Adobe\, C:\Users\<User>\AppData\Local\Temp\) and the Process Parent is a trusted installer service like msiexec.exe or wuauserv.Endpoint Backup and Archiving Operations