This hunt targets adversary behavior involving the execution of previously unidentified malware by correlating twenty specific indicators of compromise across the environment. Proactively hunting for these unknown threats in Azure Sentinel is critical to establish baseline visibility and accelerate incident response before established detection rules can be configured.
Malware Family: Unknown malware Total IOCs: 20 IOC Types: ip:port, domain
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 154[.]220[.]94[.]39:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]95[.]126:8888 | botnet_cc | 2026-07-02 | 100% |
| domain | clickhitriver.com | payload_delivery | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]93[.]235:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]123[.]189:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]122[.]107:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]122[.]114:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]121[.]50:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]123[.]170:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]123[.]165:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 102[.]117[.]171[.]174:7443 | botnet_cc | 2026-07-02 | 75% |
| domain | waysmakeyourlifebetter.com | payload_delivery | 2026-07-02 | 100% |
| domain | goodpersonofourcentury.com | payload_delivery | 2026-07-02 | 100% |
| domain | besthappyfamily.com | payload_delivery | 2026-07-02 | 100% |
| domain | authorization-code.info | payload_delivery | 2026-07-02 | 100% |
| domain | fesold.com | payload_delivery | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]121[.]35:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]120[.]254:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]120[.]231:8888 | botnet_cc | 2026-07-02 | 100% |
| ip:port | 154[.]220[.]120[.]234:8888 | botnet_cc | 2026-07-02 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Unknown malware
let malicious_ips = dynamic(["154.220.121.50", "154.220.122.107", "154.220.94.39", "154.220.123.165", "154.220.120.254", "154.220.95.126", "154.220.93.235", "154.220.122.114", "154.220.121.35", "154.220.123.189", "154.220.120.231", "154.220.120.234", "102.117.171.174", "154.220.123.170"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["154.220.121.50", "154.220.122.107", "154.220.94.39", "154.220.123.165", "154.220.120.254", "154.220.95.126", "154.220.93.235", "154.220.122.114", "154.220.121.35", "154.220.123.189", "154.220.120.231", "154.220.120.234", "102.117.171.174", "154.220.123.170"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Unknown malware
let malicious_domains = dynamic(["clickhitriver.com", "waysmakeyourlifebetter.com", "goodpersonofourcentury.com", "besthappyfamily.com", "authorization-code.info", "fesold.com"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios for the ThreatFox: Unknown malware IOCs rule, including suggested filters and exclusions tailored for an enterprise environment:
Scheduled Enterprise Antivirus Definitions Update
go.microsoft.com or api.crowdstrike.com) that have not yet been whitelisted in the ThreatFox IOC database, triggering alerts on “Unknown” file hashes and network destinations.MpCmdRun.exe, CfSvcHost.exe) and restrict the alert scope to specific Update Server IP ranges or domains known to belong to the AV vendor.Software Deployment via Configuration Management Tools
Ansible.exe, ccmexec.exe (SCCM), or TaskScheduler.exe. Additionally, filter out events originating from specific Service Accounts used for patching (e.g., svc-patch-deploy).Automated Backup and Data Archiving Jobs