This hunt detects adversary behavior involving newly identified unknown malware indicators that have not yet been incorporated into standard threat intelligence feeds. Proactively hunting for these specific IOCs in Azure Sentinel is critical to identify early-stage infections and mitigate potential lateral movement before the malware becomes widely recognized or actively exploited by other organizations.
Malware Family: Unknown malware Total IOCs: 23 IOC Types: ip:port, url, domain
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 82[.]197[.]65[.]206:7443 | botnet_cc | 2026-08-20 | 75% |
| ip:port | 169[.]58[.]75[.]138:8000 | botnet_cc | 2026-08-20 | 100% |
| domain | smokingstationhub.com | botnet_cc | 2026-08-20 | 100% |
| ip:port | 185[.]212[.]44[.]47:1010 | botnet_cc | 2026-08-20 | 75% |
| url | hxxps://taliy.sbs/auth | payload_delivery | 2026-08-20 | 100% |
| url | hxxps://tradegenius.sbs/auth | payload_delivery | 2026-08-20 | 100% |
| ip:port | 45[.]92[.]16[.]135:5480 | botnet_cc | 2026-08-20 | 75% |
| ip:port | 37[.]120[.]214[.]122:2090 | botnet_cc | 2026-08-20 | 75% |
| ip:port | 187[.]87[.]138[.]158:43260 | botnet_cc | 2026-08-20 | 75% |
| ip:port | 124[.]198[.]132[.]79:2023 | botnet_cc | 2026-08-20 | 75% |
| ip:port | 188[.]126[.]90[.]11:7777 | botnet_cc | 2026-08-20 | 75% |
| ip:port | 129[.]226[.]174[.]180:443 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 78[.]186[.]49[.]17:1337 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 193[.]233[.]130[.]223:80 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 94[.]249[.]230[.]177:80 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 84[.]71[.]50[.]253:8443 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 34[.]134[.]90[.]188:8089 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 35[.]254[.]102[.]75:8089 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 45[.]198[.]55[.]168:8089 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 141[.]125[.]158[.]53:8089 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 130[.]61[.]239[.]223:8089 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 172[.]236[.]7[.]224:8089 | botnet_cc | 2026-08-20 | 50% |
| ip:port | 91[.]134[.]62[.]41:8089 | botnet_cc | 2026-08-20 | 50% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Unknown malware
let malicious_ips = dynamic(["188.126.90.11", "78.186.49.17", "35.254.102.75", "124.198.132.79", "172.236.7.224", "169.58.75.138", "130.61.239.223", "45.92.16.135", "187.87.138.158", "45.198.55.168", "82.197.65.206", "37.120.214.122", "185.212.44.47", "193.233.130.223", "129.226.174.180", "34.134.90.188", "91.134.62.41", "94.249.230.177", "84.71.50.253", "141.125.158.53"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["188.126.90.11", "78.186.49.17", "35.254.102.75", "124.198.132.79", "172.236.7.224", "169.58.75.138", "130.61.239.223", "45.92.16.135", "187.87.138.158", "45.198.55.168", "82.197.65.206", "37.120.214.122", "185.212.44.47", "193.233.130.223", "129.226.174.180", "34.134.90.188", "91.134.62.41", "94.249.230.177", "84.71.50.253", "141.125.158.53"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Unknown malware
let malicious_domains = dynamic(["smokingstationhub.com"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Unknown malware
let malicious_urls = dynamic(["https://taliy.sbs/auth", "https://tradegenius.sbs/auth"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Here are 5 specific false positive scenarios for the ThreatFox: Unknown malware IOCs rule, along with targeted exclusion strategies suitable for an enterprise environment:
Scenario: Automated Antivirus Definition Updates via GPO
mpcmdrun.exe (Microsoft Defender) or CrowdStrikeService.exe and the event origin is a scheduled GPO task (e.g., Task Name: Antivirus Definition Update).Scenario: CI/CD Pipeline Artifact Deployment
jenkins-build-svc, azdo-agent) and restrict the scope to IP ranges dedicated to the DevOps subnet (e.g., 10.20.50.x).Scenario: Third-Party Software Patching via SCCM