This detection rule identifies potential compromise by correlating eight distinct indicators of unknown malware activity across the Azure Sentinel environment. Proactive hunting is critical to rapidly isolate these emerging threats before they establish persistence or exfiltrate sensitive data, given their high severity and lack of established signatures.
Malware Family: Unknown malware Total IOCs: 8 IOC Types: ip:port, url, domain
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 45[.]92[.]158[.]150:7443 | botnet_cc | 2026-06-29 | 75% |
| ip:port | 154[.]94[.]233[.]166:60000 | botnet_cc | 2026-06-29 | 100% |
| domain | settra5ldqwgtw5q7z5awbsvlksakyfojuc5slgrz5lvapune4fantqd.onion | botnet_cc | 2026-06-29 | 100% |
| domain | pbxvml6h3wz35qlr5muy2cg5jvjsd4qhjlsztmxj4lqkyohnfdrntqyd.onion | botnet_cc | 2026-06-29 | 100% |
| domain | 26z3gms2rshr2zzedxhw5fbucilmgt2inhmxzmuhteyztpxohoqplgyd.onion | botnet_cc | 2026-06-29 | 100% |
| domain | ttfy4zmtiaywfkkmykpxiwtlxkcr5ofvrhqgxxyspgwzbxkc3uze7jid.onion | botnet_cc | 2026-06-29 | 100% |
| domain | c3u3g7dz2yxkefci3x34jfvfa4gka4iogi4zfjkyxx2c536oqdld4kid.onion | botnet_cc | 2026-06-29 | 100% |
| url | hxxps://aheadsupport.co.uk/ | payload_delivery | 2026-06-29 | 90% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Unknown malware
let malicious_ips = dynamic(["45.92.158.150", "154.94.233.166"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["45.92.158.150", "154.94.233.166"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Unknown malware
let malicious_domains = dynamic(["settra5ldqwgtw5q7z5awbsvlksakyfojuc5slgrz5lvapune4fantqd.onion", "pbxvml6h3wz35qlr5muy2cg5jvjsd4qhjlsztmxj4lqkyohnfdrntqyd.onion", "26z3gms2rshr2zzedxhw5fbucilmgt2inhmxzmuhteyztpxohoqplgyd.onion", "ttfy4zmtiaywfkkmykpxiwtlxkcr5ofvrhqgxxyspgwzbxkc3uze7jid.onion", "c3u3g7dz2yxkefci3x34jfvfa4gka4iogi4zfjkyxx2c536oqdld4kid.onion"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Unknown malware
let malicious_urls = dynamic(["https://aheadsupport.co.uk/"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Here are 5 specific false positive scenarios for the ThreatFox: Unknown malware IOCs detection rule in an enterprise environment, along with suggested filters or exclusions:
Software Deployment via SCCM/Intune
ccmexec.exe (SCCM) or IntuneManagementExtension.exe, specifically when the file path resides within a known software distribution share (e.g., \\fileserver\Deployments\InternalApps).Scheduled Antivirus Definition Updates
SYSTEM account with command lines containing keywords like “update,” “signature,” or specific vendor names (e.g., C:\Program Files\CrowdStrike\csagent.exe) during maintenance windows (02:00 – 04:00 UTC).Development Environment Build Pipelines