This rule detects the presence of 23 known indicators of compromise associated with unidentified malware families, signaling potential active infections or staging activities within the environment. Proactively hunting for these IOCs allows the SOC team to identify and isolate compromised assets before the unknown malware can establish persistence or execute lateral movement.
Malware Family: Unknown malware Total IOCs: 23 IOC Types: ip:port, domain, sha256_hash, url
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 95[.]158[.]131[.]144:7443 | botnet_cc | 2026-09-15 | 75% |
| ip:port | 95[.]158[.]131[.]151:7443 | botnet_cc | 2026-09-15 | 75% |
| ip:port | 141[.]148[.]194[.]147:7443 | botnet_cc | 2026-09-15 | 75% |
| url | hxxps://copiose.org/test_proliv/b?o=e6d201f73896b9ca | payload_delivery | 2026-09-15 | 90% |
| url | hxxp://greenns.biz:2930/orders | botnet_cc | 2026-09-15 | 100% |
| url | hxxp://tokjoza.shop:5200/customers | botnet_cc | 2026-09-15 | 100% |
| domain | i0.hdslb.com | payload_delivery | 2026-09-15 | 90% |
| sha256_hash | 091ecb975883426d8a4451487cb6144ae8351cebd47d1d50f8afcc0670cb33c8 | payload | 2026-09-15 | 90% |
| ip:port | 178[.]16[.]54[.]148:8081 | botnet_cc | 2026-09-15 | 100% |
| ip:port | 195[.]20[.]115[.]77:3308 | botnet_cc | 2026-09-15 | 100% |
| ip:port | 91[.]219[.]236[.]179:8080 | botnet_cc | 2026-09-15 | 100% |
| sha256_hash | e2db5db12564d2a9da7ef3a57aa23d95782f5eaddc8bd35eb7c35ae6b844a0f0 | payload | 2026-09-15 | 100% |
| sha256_hash | dede8bfb55c2e6479d89b1e73e0712791cf16a7179325804fc4bc13f708d08ae | payload | 2026-09-15 | 100% |
| sha256_hash | ddbd636f6dfd475dc0c75bf9f6f873fa35b9062dee9d37b3377ae7b9acdcd0c9 | payload | 2026-09-15 | 100% |
| sha256_hash | b926cfcd3f4b07fe6001c39f46e40225ff8000411198d13782538d770c54ae5e | payload | 2026-09-15 | 100% |
| sha256_hash | bff3583d04f0d5603ced9831eb7c45c1923bd90e2f7d5e5d2b32942d38cf6dc5 | payload | 2026-09-15 | 100% |
| sha256_hash | c708d413720848f8788f43a4f47ddce016fca9af10c9ba4113f47bf2c9244dc5 | payload | 2026-09-15 | 100% |
| sha256_hash | 8745e872ff8aa41b0e03737f76bf35b6c934106c987dff98afe34120e47caf91 | payload | 2026-09-15 | 100% |
| sha256_hash | bba58f99e14e3512c04a5a74a079d7851abf935dd258cff4c80874ce7cfc82e3 | payload | 2026-09-15 | 100% |
| sha256_hash | d8f15ba122cd6da01f83fe05294df80a6eadbce0f66dac7c2bcc0904f066e0de | payload | 2026-09-15 | 100% |
| sha256_hash | 3ab56c9fb6b7c404c1e5b36788959c877ea819fb124c3847fa0498e9915ef9a7 | payload | 2026-09-15 | 100% |
| sha256_hash | 7b82f08120e0d9b16cd5b9ec59d24fb68e35735c82311a233d370e7f264af650 | payload | 2026-09-15 | 100% |
| sha256_hash | B738c03fef5e3d26419e4aab1818a0a7ad206c67fb3eeedcdfb3ef1ee07eb620 | payload | 2026-09-15 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Unknown malware
let malicious_ips = dynamic(["95.158.131.151", "195.20.115.77", "95.158.131.144", "91.219.236.179", "178.16.54.148", "141.148.194.147"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["95.158.131.151", "195.20.115.77", "95.158.131.144", "91.219.236.179", "178.16.54.148", "141.148.194.147"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Unknown malware
let malicious_domains = dynamic(["i0.hdslb.com"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Unknown malware
let malicious_urls = dynamic(["https://copiose.org/test_proliv/b?o=e6d201f73896b9ca", "http://greenns.biz:2930/orders", "http://tokjoza.shop:5200/customers"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
// Hunt for files matching known malicious hashes
// Source: ThreatFox - Unknown malware
let malicious_hashes = dynamic(["091ecb975883426d8a4451487cb6144ae8351cebd47d1d50f8afcc0670cb33c8", "e2db5db12564d2a9da7ef3a57aa23d95782f5eaddc8bd35eb7c35ae6b844a0f0", "dede8bfb55c2e6479d89b1e73e0712791cf16a7179325804fc4bc13f708d08ae", "ddbd636f6dfd475dc0c75bf9f6f873fa35b9062dee9d37b3377ae7b9acdcd0c9", "b926cfcd3f4b07fe6001c39f46e40225ff8000411198d13782538d770c54ae5e", "bff3583d04f0d5603ced9831eb7c45c1923bd90e2f7d5e5d2b32942d38cf6dc5", "c708d413720848f8788f43a4f47ddce016fca9af10c9ba4113f47bf2c9244dc5", "8745e872ff8aa41b0e03737f76bf35b6c934106c987dff98afe34120e47caf91", "bba58f99e14e3512c04a5a74a079d7851abf935dd258cff4c80874ce7cfc82e3", "d8f15ba122cd6da01f83fe05294df80a6eadbce0f66dac7c2bcc0904f066e0de", "3ab56c9fb6b7c404c1e5b36788959c877ea819fb124c3847fa0498e9915ef9a7", "7b82f08120e0d9b16cd5b9ec59d24fb68e35735c82311a233d370e7f264af650", "B738c03fef5e3d26419e4aab1818a0a7ad206c67fb3eeedcdfb3ef1ee07eb620"]);
DeviceFileEvents
| where SHA256 in (malicious_hashes) or SHA1 in (malicious_hashes) or MD5 in (malicious_hashes)
| project Timestamp, DeviceName, FileName, FolderPath, SHA256, InitiatingProcessFileName
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceFileEvents | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
libcurl or openssl) which shares a specific hash or file path with one of the 23 IOCs.
/usr/lib/, /opt/app/lib/) and the process is initiated by dockerd or containerd-shim.C:\Users\Public\Temp directory, which inadvertently deletes or creates a file matching an IOC’s filename or hash during a routine cleanup cycle.
powershell.exe and the command line contains parameters like -Delete, -Remove-Item, or -Clean, specifically targeting paths under C:\Users\Public\ or C:\Windows\Temp\..so or .dll) into the system’s temporary directories to test for specific exploits, triggering hash-based IOCs.
nessus.exe, qualys_agent.exe, or scanner.exe, and the file path contains /tmp/, /var/tmp/, or C:\Windows\Temp\.pg_dump or mysqldump that writes large data files to a network share or local disk, where the resulting file hash coincidentally matches an IOC due to similar data structures or compression algorithms