← Back to SOC feed Coverage →

ThreatFox: Unknown malware IOCs

ioc-hunt HIGH ThreatFox
DeviceFileEventsDnsEventsUrlClickEvents
iocthreatfoxunknown
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at ThreatFox →
Retrieved: 2026-09-06T11:00:01Z · Confidence: high

Hunt Hypothesis

This hypothesis targets the presence of seven specific indicators of compromise linked to unknown malware, which may indicate an active or dormant infection within the environment. Proactively hunting for these IOCs in Azure Sentinel is critical to identify and contain potential threats before they escalate, given the high severity and the lack of a defined MITRE technique that could otherwise mask the activity.

IOC Summary

Malware Family: Unknown malware Total IOCs: 7 IOC Types: url, md5_hash, domain, sha256_hash

TypeValueThreat TypeFirst SeenConfidence
domainrobinfireman.xyzbotnet_cc2026-09-06100%
sha256_hash2001073e86fb819f81ddfbad029f8bccceb6e877df74e24f140e06d29ed9457epayload2026-09-06100%
sha256_hashf6e001270f7197b715a2181b35ebb3ce0b61344d3fcbe7f78d4ade407f0558afpayload2026-09-06100%
md5_hash188c0c633c07dd5eac1d770132450c3apayload2026-09-06100%
md5_hash124ea0becb2b4885c536884d42f969afpayload2026-09-06100%
urlhxxps://sites.google.com/view/facturacion2026mxpayload_delivery2026-09-06100%
urlhxxps://dipag.com.mx/api/comprobante/index.htmlpayload_delivery2026-09-06100%

KQL: Domain Hunt

// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Unknown malware
let malicious_domains = dynamic(["robinfireman.xyz"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc

KQL: Url Hunt

// Hunt for access to known malicious URLs
// Source: ThreatFox - Unknown malware
let malicious_urls = dynamic(["https://sites.google.com/view/facturacion2026mx", "https://dipag.com.mx/api/comprobante/index.html"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc

KQL: Hash Hunt

// Hunt for files matching known malicious hashes
// Source: ThreatFox - Unknown malware
let malicious_hashes = dynamic(["2001073e86fb819f81ddfbad029f8bccceb6e877df74e24f140e06d29ed9457e", "f6e001270f7197b715a2181b35ebb3ce0b61344d3fcbe7f78d4ade407f0558af", "188c0c633c07dd5eac1d770132450c3a", "124ea0becb2b4885c536884d42f969af"]);
DeviceFileEvents
| where SHA256 in (malicious_hashes) or SHA1 in (malicious_hashes) or MD5 in (malicious_hashes)
| project Timestamp, DeviceName, FileName, FolderPath, SHA256, InitiatingProcessFileName
| order by Timestamp desc

Required Data Sources

Sentinel TableNotes
DeviceFileEventsEnsure this data connector is enabled
DnsEventsEnsure this data connector is enabled
UrlClickEventsEnsure this data connector is enabled

References

False Positive Guidance

Original source: https://threatfox.abuse.ch/browse/malware/unknown/