The ThreatFox: Unknown malware IOCs rule detects potential adversary activity involving unknown malicious indicators that may be associated with advanced persistent threats. SOC teams should proactively hunt for this behavior in Azure Sentinel to identify and mitigate emerging threats before they cause significant damage.
IOC Summary
Malware Family: Unknown malware Total IOCs: 32 IOC Types: ip:port, sha256_hash, url, domain
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| domain | sp13.gstats-api-cont.co | botnet_cc | 2026-05-19 | 100% |
| ip:port | 167[.]86[.]114[.]91:7443 | botnet_cc | 2026-05-19 | 75% |
| url | hxxp://85[.]239[.]155[.]68:3001/internal/log | botnet_cc | 2026-05-19 | 100% |
| url | hxxp://85[.]239[.]155[.]68:3001/upload | botnet_cc | 2026-05-19 | 100% |
| ip:port | 85[.]239[.]155[.]68:3001 | botnet_cc | 2026-05-19 | 100% |
| url | hxxp://85[.]239[.]155[.]68:3001/ws | botnet_cc | 2026-05-19 | 100% |
| ip:port | 95[.]85[.]236[.]201:3652 | botnet_cc | 2026-05-19 | 75% |
| domain | cybersec-chile.online | botnet_cc | 2026-05-19 | 100% |
| ip:port | 45[.]149[.]154[.]220:8443 | botnet_cc | 2026-05-19 | 75% |
| domain | capcutdev.com | payload_delivery | 2026-05-19 | 80% |
| domain | log32-normal.capcutdev.com | payload_delivery | 2026-05-19 | 80% |
| ip:port | 79[.]110[.]50[.]15:443 | payload_delivery | 2026-05-19 | 80% |
| ip:port | 65[.]87[.]7[.]128:443 | payload_delivery | 2026-05-19 | 80% |
| domain | cloud.integritybusinessolutions.com | payload_delivery | 2026-05-19 | 80% |
| url | hxxp://79[.]110[.]50[.]15:8089/borlndmm.dll | payload_delivery | 2026-05-19 | 80% |
| sha256_hash | 78be219b8793d648213172a6bc2c1738f4e14f7b65a01d2d875e40c858e1b484 | payload | 2026-05-19 | 75% |
| sha256_hash | 6c974418247ab414c674fb699ee001d1703f8a6c54810b1773cdc1647cc69e52 | payload | 2026-05-19 | 75% |
| sha256_hash | d0c2fe58efadb86c93f9930cb8668cd40b60399f3a8db54b1c9974ee4eab4b39 | payload | 2026-05-19 | 75% |
| sha256_hash | b2af4e6e723b7a8074ed41a90da69c6cd1b1db4fc4cc8a2e2930daa58704443c | payload | 2026-05-19 | 75% |
| sha256_hash | 52461a7264164f0e8d1723ef0b76e99f394936b5290df25a5f26c8552a01369a | payload | 2026-05-19 | 75% |
| sha256_hash | 9a6b750766ff30309502a31bf3bacae5c60211f2257c446c114f28148d2f4fd8 | payload | 2026-05-19 | 85% |
| domain | take.takemetotheriver.top | botnet_cc | 2026-05-19 | 100% |
| domain | hey.wtfomginc.top | botnet_cc | 2026-05-19 | 100% |
| domain | ds.emailmeanything.sbs | botnet_cc | 2026-05-19 | 100% |
| domain | top.realslimshady.xyz | botnet_cc | 2026-05-19 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Unknown malware
let malicious_ips = dynamic(["65.87.7.128", "62.181.55.38", "45.149.154.220", "79.110.50.15", "167.86.114.91", "95.85.236.201", "85.239.155.68"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["65.87.7.128", "62.181.55.38", "45.149.154.220", "79.110.50.15", "167.86.114.91", "95.85.236.201", "85.239.155.68"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Unknown malware
let malicious_domains = dynamic(["sp13.gstats-api-cont.co", "cybersec-chile.online", "capcutdev.com", "log32-normal.capcutdev.com", "cloud.integritybusinessolutions.com", "take.takemetotheriver.top", "hey.wtfomginc.top", "ds.emailmeanything.sbs", "top.realslimshady.xyz", "92.dmrdjmejuah.icu", "real.kabgagk234d.info", "set.setmeasdomain.cyou", "omg.itsjasonborn.today", "oh.whatisyourname.buzz", "api.itsjusttesting.top"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
// Hunt for access to known malicious URLs
// Source: ThreatFox - Unknown malware
let malicious_urls = dynamic(["http://85.239.155.68:3001/internal/log", "http://85.239.155.68:3001/upload", "http://85.239.155.68:3001/ws", "http://79.110.50.15:8089/borlndmm.dll"]);
UrlClickEvents
| where Url has_any (malicious_urls)
| project Timestamp, AccountUpn, Url, ActionType, IsClickedThrough
| order by Timestamp desc
// Hunt for files matching known malicious hashes
// Source: ThreatFox - Unknown malware
let malicious_hashes = dynamic(["78be219b8793d648213172a6bc2c1738f4e14f7b65a01d2d875e40c858e1b484", "6c974418247ab414c674fb699ee001d1703f8a6c54810b1773cdc1647cc69e52", "d0c2fe58efadb86c93f9930cb8668cd40b60399f3a8db54b1c9974ee4eab4b39", "b2af4e6e723b7a8074ed41a90da69c6cd1b1db4fc4cc8a2e2930daa58704443c", "52461a7264164f0e8d1723ef0b76e99f394936b5290df25a5f26c8552a01369a", "9a6b750766ff30309502a31bf3bacae5c60211f2257c446c114f28148d2f4fd8"]);
DeviceFileEvents
| where SHA256 in (malicious_hashes) or SHA1 in (malicious_hashes) or MD5 in (malicious_hashes)
| project Timestamp, DeviceName, FileName, FolderPath, SHA256, InitiatingProcessFileName
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceFileEvents | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
UrlClickEvents | Ensure this data connector is enabled |
Scenario: A system administrator is using PowerShell to run a scheduled job that downloads a legitimate update from a known Microsoft server.
Filter/Exclusion: Exclude all IOCs that match Microsoft update servers (e.g., *.download.microsoft.com, *.windowsupdate.com).
Scenario: A DevOps engineer is using Ansible to deploy a configuration management script that includes a known benign file from a company repository.
Filter/Exclusion: Exclude IOCs that match internal artifact repositories (e.g., *.artifactory.internal, *.nexus.internal).
Scenario: A database administrator is using SQL Server Agent to run a job that connects to a remote SQL server for data synchronization.
Filter/Exclusion: Exclude IOCs that match internal SQL server IP ranges or FQDNs (e.g., *.sqlserver.corp, 10.0.0.0/8).
Scenario: A security analyst is using Wireshark to analyze network traffic and saves a pcap file to a local machine for forensic analysis.
Filter/Exclusion: Exclude IOCs that match local file paths used by forensic tools (e.g., C:\Users\Analyst\Desktop\*.pcap, C:\Tools\Wireshark\).
Scenario: A system administrator is using Windows Task Scheduler to run a script that queries a public API for system health metrics.
Filter/Exclusion: Exclude IOCs that match known public APIs (e.g., api.example.com, metrics.example.org).