This detection rule identifies unknown Remote Access Trojan (RAT) indicators that may signal an adversary establishing covert command and control channels within the network. Proactively hunting for these specific IOCs in Azure Sentinel is critical to uncover stealthy RAT deployments before they can exfiltrate sensitive data or facilitate lateral movement across the environment.
Malware Family: Unknown RAT Total IOCs: 2 IOC Types: ip:port, domain
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 91[.]193[.]7[.]186:48988 | botnet_cc | 2026-09-02 | 75% |
| domain | out-agent.duckdns.org | botnet_cc | 2026-09-02 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Unknown RAT
let malicious_ips = dynamic(["91.193.7.186"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["91.193.7.186"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - Unknown RAT
let malicious_domains = dynamic(["out-agent.duckdns.org"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios for the ThreatFox: Unknown RAT IOCs detection rule, along with recommended filters and exclusions:
Scenario 1: Automated Security Scanning by EDR Agents
SYSTEM, LocalService) or whitelisting known EDR vendor IP ranges and process paths (e.g., C:\Program Files\CrowdStrike\fsquint.exe).Scenario 2: Scheduled Cloud Backup and Synchronization Jobs
01:00–04:00 UTC) or add the backup service executable paths (e.g., C:\Program Files\Veeam\Backup and Replication\Engine\vbengine.exe) to the allowlist.Scenario 3: IT Admin Remote Management Sessions