This hunt targets adversary activity involving known AdaptixC2 command-and-control infrastructure by correlating network traffic against a specific set of 14 Indicators of Compromise. Proactively hunting for these IOCs in Azure Sentinel is critical to identify early-stage lateral movement or data exfiltration attempts before they escalate into full-blown incidents within the cloud environment.
Malware Family: AdaptixC2 Total IOCs: 14 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 45[.]136[.]13[.]247:8888 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 154[.]219[.]115[.]123:60002 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 45[.]136[.]13[.]247:8443 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 38[.]242[.]212[.]5:80 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 38[.]242[.]212[.]5:8080 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 38[.]242[.]212[.]5:443 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 38[.]242[.]212[.]5:1390 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 154[.]219[.]115[.]123:80 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 1[.]92[.]135[.]168:443 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 178[.]105[.]144[.]206:4321 | botnet_cc | 2026-07-19 | 75% |
| ip:port | 1[.]92[.]135[.]168:8080 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 154[.]219[.]115[.]123:8080 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 154[.]219[.]115[.]123:443 | botnet_cc | 2026-07-19 | 100% |
| ip:port | 45[.]77[.]89[.]29:9000 | botnet_cc | 2026-07-19 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - AdaptixC2
let malicious_ips = dynamic(["38.242.212.5", "45.136.13.247", "154.219.115.123", "178.105.144.206", "45.77.89.29", "1.92.135.168"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["38.242.212.5", "45.136.13.247", "154.219.115.123", "178.105.144.206", "45.77.89.29", "1.92.135.168"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios for the ThreatFox: AdaptixC2 IOCs detection rule, tailored for an enterprise environment:
Endpoint Protection Policy Updates via Microsoft Defender for Endpoint
Microsoft Defender Antivirus service to known AdaptixC2 infrastructure IPs (often used by third-party threat intelligence feeds integrated into Defender) to validate signatures before deployment.MDE-Admin-SVC) connecting to the AdaptixC2 IP range during standard maintenance windows (e.g., 01:00–04:00 UTC).Scheduled Enterprise Backup Jobs using Veeam or Commvault
VeeamAgent.exe (or vbrservice) and the destination port matches the specific AdaptixC2 beacon ports, provided the connection duration exceeds 30 seconds (indicating a bulk data transfer rather than a short C2 heartbeat).Patch Management Deployments via SCCM or Intune
WUAuserv service on client machines queries external repositories to download critical security patches.