This hunt targets adversary behavior involving the deployment of AsyncRAT remote access trojans by monitoring for specific indicators of compromise such as malicious network connections and file artifacts. Proactively hunting for these IOCs in Azure Sentinel is critical because early detection of this high-severity threat enables rapid containment before attackers can establish persistent command-and-control channels or exfiltrate sensitive data.
Malware Family: AsyncRAT Total IOCs: 7 IOC Types: domain, ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| domain | ratsales.duckdns.org | botnet_cc | 2026-07-14 | 75% |
| domain | robin43hf.duckdns.org | botnet_cc | 2026-07-14 | 75% |
| domain | ferjksax.duckdns.org | botnet_cc | 2026-07-14 | 75% |
| ip:port | 198[.]135[.]49[.]85:62025 | botnet_cc | 2026-07-14 | 75% |
| ip:port | 130[.]49[.]214[.]23:59838 | botnet_cc | 2026-07-14 | 75% |
| ip:port | 13[.]53[.]169[.]83:8808 | botnet_cc | 2026-07-14 | 100% |
| ip:port | 13[.]53[.]169[.]83:7000 | botnet_cc | 2026-07-13 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - AsyncRAT
let malicious_ips = dynamic(["13.53.169.83", "130.49.214.23", "198.135.49.85"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["13.53.169.83", "130.49.214.23", "198.135.49.85"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
// Hunt for DNS queries to known malicious domains
// Source: ThreatFox - AsyncRAT
let malicious_domains = dynamic(["ratsales.duckdns.org", "robin43hf.duckdns.org", "ferjksax.duckdns.org"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses, QueryType
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
Here are specific false positive scenarios for the ThreatFox: AsyncRAT IOCs detection rule in an enterprise environment, along with recommended filters or exclusions:
Endpoint Protection Agent Updates and Scans
NT AUTHORITY\SYSTEM, CrowdStrike Falcon Service) and destination IPs belonging to the organization’s primary security vendor update servers.Scheduled Software Deployment via SCCM or Intune
ccmexec.exe, Microsoft.Ingestion.Service, IntuneManagementExtension) and restrict the detection to non-maintenance windows (e.g., exclude 02:00–06:00 UTC) or specific distribution point IP ranges.IT Administration Remote Management Sessions