This hunt targets adversary behavior characterized by the deployment of Cobalt Strike beacons across the network to establish persistent command and control channels. Proactively hunting these specific indicators in Azure Sentinel is critical for early detection of advanced post-exploitation activities before they escalate into significant lateral movement or data exfiltration events.
Malware Family: Cobalt Strike Total IOCs: 14 IOC Types: ip:port
| Type | Value | Threat Type | First Seen | Confidence |
|---|---|---|---|---|
| ip:port | 159[.]94[.]211[.]163:14443 | botnet_cc | 2026-07-18 | 75% |
| ip:port | 158[.]94[.]211[.]163:14443 | botnet_cc | 2026-07-18 | 75% |
| ip:port | 47[.]101[.]51[.]235:1099 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 47[.]101[.]51[.]235:8000 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 47[.]101[.]51[.]235:8888 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 45[.]87[.]53[.]6:5003 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 45[.]87[.]53[.]6:18082 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 45[.]87[.]53[.]6:8888 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 43[.]167[.]177[.]224:6666 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 43[.]167[.]177[.]224:22 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 43[.]144[.]20[.]144:5004 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 43[.]144[.]20[.]144:53 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 43[.]144[.]19[.]224:5004 | botnet_cc | 2026-07-18 | 100% |
| ip:port | 43[.]144[.]20[.]144:3306 | botnet_cc | 2026-07-17 | 100% |
// Hunt for network connections to known malicious IPs
// Source: ThreatFox - Cobalt Strike
let malicious_ips = dynamic(["45.87.53.6", "43.167.177.224", "43.144.19.224", "47.101.51.235", "158.94.211.163", "159.94.211.163", "43.144.20.144"]);
CommonSecurityLog
| where DestinationIP in (malicious_ips) or SourceIP in (malicious_ips)
| project TimeGenerated, SourceIP, DestinationIP, DestinationPort, DeviceAction, Activity
| order by TimeGenerated desc
// Hunt in Defender for Endpoint network events
let malicious_ips = dynamic(["45.87.53.6", "43.167.177.224", "43.144.19.224", "47.101.51.235", "158.94.211.163", "159.94.211.163", "43.144.20.144"]);
DeviceNetworkEvents
| where RemoteIP in (malicious_ips)
| project Timestamp, DeviceName, RemoteIP, RemotePort, InitiatingProcessFileName, ActionType
| order by Timestamp desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DeviceNetworkEvents | Ensure this data connector is enabled |
Here are 5 specific false positive scenarios for the ThreatFox: Cobalt Strike IOCs detection rule in an enterprise environment, along with suggested filters or exclusions:
Endpoint Protection Scanning of Software Repositories
beacon.exe) and its associated DLLs for deployment to new endpoints. When the Windows Defender Antivirus service scans these repository folders, it triggers file hash matches against the 14 IOCs, even though no active attack is occurring.C:\Program Files\Microsoft Configuration Manager\Client or \\fileserver\SoftwareDeploy\CobaltStrike) and exclude processes initiated by the antimalware service (MsMpEng.exe).Scheduled Maintenance for Security Tool Updates
C:\Temp\SecOps_Updates) before pushing them out. The extraction process generates file creation events that match the detection logic’s IOCs.C:\Temp\SecOps_Updates directory and excluding parent processes named powershell.exe spawned by TaskScheduler.Red Team Exercise and Internal Penetration Testing